Question

Alarm not working on Google Assistant


Userlevel 1
Alarms don't seem to be set through Google Assistant.

Steps to reproduce:

  1. "Hey Google, set an alarm for xxx"
  2. Google responds that alarm is set
  3. "Hey Google, what alarms do I have set?"
  4. Google responds that no alarms have been set

25 replies

I am experiencing the exact same issue! I reached out to Google first and they directed me to Sonos. After talking to Sonos for two days, they got fed up trying to 'resolve' the issue. Their response was: "The functionality has not been officially released in your region. While features and functionality may work, your region is currently unsupported and we are not able to provide support for anything that may not work." Strange that it randomly stopped working after working flawless for 2+ months.
Userlevel 3
Badge +4
Same here. Alarms have been working fine since Google Assistant first became available on Sonos and then they stopped.

I don't expect any response from Sonos. Their support is abysmal. Also still waiting to find out from them what's happening with sleep timers.
Same problem here. Worked previously, lucky I had set 2 different alarms to wake me up. I set an alarm on Sonos one. Google tells me it’s set. If I ask what alarms are set it says none and alarm doesn’t go off. What is going on? Tried disabling and reconnecting and it’s still the same!
Same issue here. Looks like there’s no solution.
Same issue
Same problem here. Are there no work arounds?
All I can say is "same here". And Sonos Netherlands know nothing and are friendly but unhelpful.
Same issue here.... seems like it’s easy to sell products and advertise features that don’t work and then hide and ignore your customers
Same here
Yeah, same here. It was working fine until recently. I set 2 alarms to wake me up for work and none of them worked. Luckily my phone was close enough to hear me as well lol..
Now if I ask to set an alarm, I get the response that it has been set. But if I then immediately ask if there's any alarms set, there is none
Badge
Sorry to say that, but I just tried it and I don't have this problem.
Example:
"Hey Google, set an alarm for 6pm"
"Your alarm has been set" (or sth along these lines)
"Hey Google, which alarms I have set?"
"You have an alarm set for 6pm"

Maybe slight off-topic: I am wondering if it is possible to set an actual Sonos alarm via voice commands (the one you can set in the Control to wake you up with specific music).
Userlevel 7
Badge +20
Hi folks,

If you're having this issue, please run through our troubleshooting guide. If that doesn't help, give us a call. Our phone team can help troubleshoot the issue live.
I’m having the same issue as goweb what are sonos doing about it ? My google home in the kitchen is working fine so it’s definitely a Sonos issue ! If not I will have to go back to Alexa !
Badge +1
Same here 🙄
Same here in Singapore. Was happily setting alarms with google assistant on Sonos ever since launch and in last couple of weeks.

  1. "Hey Google, set an alarm for xxx"
  2. Google responds that alarm is set
  3. "Hey Google, what alarms do I have set?"
  4. Google responds that no alarms have been set
whats going on Sonos?
Same problem here in Denmark. Just moved from Alexa to Google assistant on my Sonos One - I guess I will be going back to Alexa, because I use the alarm feature every day. sigh... I wanted to use Google assistant, but I guess not then 😞
Badge
I just tried to set an alarm by voice command. I asked to set an alarm for 11 pm and when I asked to tell me my alarms, it tells me that I have one alarm set for 5 am snooze to 11 pm. The alarm still worked and played at 11 pm.

I found 2 main problems when I set an alarm by voice command:
  1. My sonos one uses the current volume for the alarm. This is a problem because if I set the alarm without increasing the volumen I will sleep through it.
  2. I can't set an alarm with a specific artist, song, playlist. GA asks me for the song I want to use and it tells me that it can't understand it or cant use [song's name]
To be honest I prefer to set the alarms with the sonos app. I made a playlist in Spotify and linked it with the alarm I wanted to play it. I even chose the Shuffle option (which can be tricky sometimes using voice command) and put a time limit of 30 minutes so I can do my mourning routine while hearing the playlist.
Same problem here...
Any sign of a fix yet?
Userlevel 2
Badge +4
I'm seeing the exact same problem. I know for a fact that it used to work pretty well (I'm in Canada) but last night I have someone over and was happy to tell her: "You don't need your phone, my personal assistant will wake us tomorrow and you won't miss your important meeting".

She was uncertain and wary of those technologies so, to reassure her, I asked "When is my alarm set" to which I was told "You have no alarm set"!!! WTF. Tried 5-6 times, same problem again. It was working fine before.

PS: I just realized, it could be the case that when it was working fine, it was when I was using Alexa. I'm not sure anymore.
I'm the same here in Canada. Just bought my Sonos One gen2 two weeks ago, set it up and the alarm has never worked.
It's a must-have for our house and there seems to be no fix in sight.
I have a google home mini and the alarm function works just fine. The function used to work on my Sonos One, it stopped working a few weeks ago. I removed the Google Assistant option from the Sonos One as recommended by the Sonos trouble shooting guide, rebooted and reinstalled the Google Assistant. Same problem, no change. Really seems like a Sonos problem, would be nice if someone from Sonos would acknowledge the problem and label this a "known issue" which they are working to resolve.
Seems like the newest update solved the problem... hurra 🙂
Two steps forward ... yes, the alarm function is now working but when you ask google if there are any alarms set it says “the alarm is set for x:xx time with a snooze for x:xx time.” The alarm time is correct, the snooze time is something new. I sense another update coming soon.
Userlevel 2
Badge +1
Ours worked initially, then some time back ceased working. As others report, it now verifies that it's understood the command, leading you to assume the alarm is indeed set. The alarm never goes off, and any subsequent queries reveal that it has no knowledge of a set alarm. When the alarms were working we had to use "Ok Google, stop", whereas Google Nest devices will cancel an alarm with just "stop".

We've had to resort to using Google Nest devices in other rooms to set alarms. It's a great shame, we've been very happy with the Beam, but if they can't get the Google Assistant integration resolved, we won't be buying anything else.
Same here,
any alarm I set seems to be set for 5 am snoozed until xx (actual alarm). Then the alarm rings and snooze function is not available. I ask google assistant to snooze, it responds correctly, yet the alarm sound still goes off. If I use the command stop after I ask it to snooze it just deletes the alarm. Sonos get on in please as I don’t even trust these alarms anymore.

Reply