After upgrading to S2, can't use Google Assistant

  • 22 April 2021
  • 4 replies


Despite the “we won’t support your old speakers” fiasco, I bought a Sonos Roam. What could go wrong buying a Bluetooth speaker that works with Sonos? I have to upgrade to S2. So I did, and had to split my system. I still don’t have the S1 system working even after 2 hours on chat with support yesterday as it still sees the new speakers. So I’ve put that on hold, and trying to get S2 to work. All compatible speakers including the Roam are visible in S2. Sonos is linked to Google Home. But I don’t see any speakers other than the Roam. When I reconnect Sonos in Google Home, all speakers show up for a few seconds, then disappear. In the S2 app, Settings/Services & Voice/Google Assistant shows only the Roam under Sonos Products. The speakers do appear in Google Home for a short thile, before disappearing. Has anyone seen this? I can’t face more time chatting with support, resetting speakers, turning my phone on and off. With S1, I was very impressed with Google integration.


Best answer by David_127 25 April 2021, 13:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +18

Hi @David_127 

Welcome to the Sonos Community!

That sounds pretty frustrating. First, please manually check for Sonos updates.

If you remove Google Assistant from the Roam, do the other rooms show in Google again, or are they still missing? Similarly, do they show as having GA installed in the Sonos app?



Hi, thanks for getting back to me. In S2, when I check for updates, it tells me the system is up to date.

I don’t think I need any more support with this at the moment. I was making notes of things I tried, but feel free not to review them unless they are useful background for other people’s issues. It seems that some things just start to work after some time. Which is a bit disconcerting, but the end result seems ok.

I hope I don’t have issues after re-installing S1 and setting up my old speakers. I’ll post another question if so.



Getting it working meant I had  through a few set-up tasks multiple times. I’ve described some of the steps below, but it’s likely not much use to you. Some of the steps are pretty circular. I am now able to play music to most of the speakers that were upgraded to S2 using a voice command to GA on my phone or a Google speaker, but remaining problems were:

 - bathroom Play3 speaker was not added even after multiple “Reconnect Sonos” attempts in Google Home

   - I don’t mind much about this, so will live with it.

   - Now after 15 minutes it’s magically appeared

 - Sonos Roam was not listening for GA commands - got error when I try to add it to GA. It already showed up in Google Home so I could play music to it, but didn’t listen (even with microphone light on). Then I tried to add it again and now it’s working. Maybe some temporary duplicate name issue between Google Home and Sonos as I’d re-added the Roam. Actually, it worked after  I renamed “Sonos Roam” to “Portable” in Google Home.


Other info asked for and steps tried:

When I went to System/Services & Voice/ Add a Voice Assitant/Add Google Assistant/Add to Sonos, it showed me only the Roam.

I have removed Google Assistant from the Roam. I didn’t see the other speakers when I went to add Google Assistant. 

I reset the Sonos Roam and did not re-add it to S2 until after the steps below. I reset the S2 app. 

I added Google Assistant, and after a few seconds it showed me GA. Then my old speakers showed up in Google Home as expected. But when I tried to play something, it said <speaker name is not available right now>. It’s almost as if GA was looking for the old S1 version of the speakers.

So I unlinked Sonos in GA. Went to add Sonos in GA. Logged in. is shown: Says “Go to the Sonos App”. When I did, it launched S1. So I uninstalled S1. Next time, I “Go to Sonos App” it says “You need the latest Sonos App”. I have it - the lastest version of S2 installed. Click on Update the Sonos App anyway. It launches S2. My speakers show up, but are not linked to GA. And Sonos is not linked in GA.

Add Google Assistant->Continue->Register Your Speakers (because I have already logged on)→Go to the Sonos App->You need the latest Sonos App (After you update, go to Settings->My Sonos Account to link your speakers)->Update App->launches S2 - no speakers added

I’ve been through this process a few times now, both by initiating the add of Sonos from Google Home or the add of GA from Sonos. At one point I was asked to give permission for GA to control Sonos. I said yes, and it added 1 speaker only - Living Room, a playbar. My speakers Study, Bathroom and kitchen are also on and should have been added.

Update: I went through the process again - after powering up the sub and surrounds from Living Room. Now my Kitchen and Bathroom speakers are added as well as Living Room. But bathroom is still not on the Assistant.

Now, re-add Sonos Roam… OK, now I can speak to GA on my phone or Google speaker and play music on Roam or my old S1 speakers except Bathroom. I reset Bathroom yesterday, do I need to register it again? But I can’t get a response from the Sonos Roam. Before resetting it, I did get a response (not the one I wanted but that’s another problem). [OK Now after renaming Sonos Roam in Google Home]

Userlevel 7
Badge +18

Hi @David_127 

Thanks for updating us, and for providing all that information.

What router do you have, and have you tried rebooting it by switching it off for 30 seconds?



The router is a Google Nest. As I mentioned above, the problem is resolved. So fortunately I don't need to continue switching components in and off.