Won't connect via WiFi using Netgear N300 WNR2200 Wireless Router


Userlevel 2
Now that I've got a new router (Netgear N300 WNR2200 Wireless Router), the Android & PC controller will not connect when using WiFi, but it does work from the PC when using a wired connection. (I have tried resetting the controller, turning uPnP off, power cycling everything etc.)

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Userlevel 2
I just wanted to add that, if I turn off the WiFi in the new router and use my old Netgear WG602 v3 instead, it works OK. So it seems to be a problem with the WiFi side of the new router and Sonos equipment. (The new router's WiFi works great for everything else.)
Userlevel 2
SOLVED! I had to uncheck the "Enable Wireless Isolation" option in the new router's configuration screen. It's not a setting that I was familiar with, but when checked (which was the default), wireless devices can access the internet, but not the LAN (i.e. not the server or the Sonos equipment).
Userlevel 5
Badge +1
Hello Alan, Way to go! I'm glad you were able to figure it out. Wireless isolation is a security feature that does not allow wireless clients to talk to wired clients. This is typically off by default on most routers. Please let us know if you have any further issues or there is anything else we can assist you with. Thanks!
Userlevel 2
Hi I have similar problems with my new Netgear Router (N300) except I cannot locate any of my Sonos components or setup my Sonos system which worked perfectly well with my old router and which will still work with old modem (albeit it has a fault which means I need to reste it frequently, hence the new router). Can you help? In frustration, Paul
Userlevel 2
Hi Paul Have you unchecked the "Enable Wireless Isolation" option in the router's configuration screen? Alan
Userlevel 2
Alan, Yes. I have just tried this (unchecked) and then restarted my Bridge but still no joy. Any other ideas? Thanks Paul
Userlevel 2
Having unchecked the "Enable wireless isolation" I can now see the various devices on my network with the exception of my Bridge which is connected into the router. Paul
Userlevel 5
Badge +1
Hello Paul, Anytime your router is replaced, you have to reboot all of your Sonos devices. Unplug them all from power and plug them back in. After about a minute, the units should pop up on your controllers. If you're not able to get them to connect, please contact our support team by phone so we can troubleshoot in real time. Our contact information can be found here: http://www.sonos.com/contact Thanks!
where is the routers configuration screen?
found the configuation screen without any help but the enable wireless isolation box was already unchecked when I signed in to it.  Now what?
My wifi won't work, what should I do?