Stop Alarm from Looping


I believe ever since an update was done this year that introduced the Snooze feature on the alarm, the alarm constantly loops.

So I might be out of the house and come back after many hours and the alarm will still be playing.
Is there not a simple option of UNlooping the alarm to stop this from happening?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +21
When you set the Alarm you set the duration. The alarm should stop after that time. Check the alarms are correctly set-up with a finite duration. If still playing up then you may have other issues. You could submit a diagnostic after the alarm fails to stop and post the number here or call Sonos
Hmm not sure if im seeing what you're seeing. I have attached a screenshot.
Then minimum duration i can set it to is 5 minutes. I dont see any option for finite duration.

I have looked around at other posts and realised that many people are having the same issues.

Userlevel 7
Badge +21
Your alarm has been set for a finite time (5 minutes). Therefore it should stop after 5 minutes - I was saying make sure the duration is NOT set to "No end". Which it isn't per your screenshot.

You may have network issues whereby for some reason your speaker gets the command to start playing but the command to stop is lost.
I suggest as a first off you reboot the system - Turn off power to router, Sonos, computers and EVERY device connected to network (phones, tablets and so on). Then switch on power to router, wait a few minutes. If you have a Boost or Bridge then switch that on and wait a few minutes. Then switch on your Sonos speakers, then the other devices.

If it still continues then submit a diagnostic after it happens and post the number here