Problems with Sonos Connecting to iTunes via Synology NAS

  • 9 September 2022
  • 19 replies

Badge +1

I’m dredging up what seems like an older topic, but one with conflicting answers out there--connecting Sonos to an iTunes database on a Sinology NAS.

A few months ago, my Sonos system stopped connecting to my iTunes database, hosted on a Synology NAS with their latest DSM software. I'm not sure if the problem started with an update to the Synology’s DSM, or something else. I deleted and re-added the library, but to no avail. It’s odd, the library indexes, but whenever I try to play a song it says that the file cannot be found. 

I did some initial online research, and saw that there--at least previously--had been issues because Sonos would only work with SMB1. But then I saw other posts that suggested the problem had been solved.

Fast forward a few months, and I finally had the time today to call Synology support. After two calls, nothing solved, second tech said they’d call me back in five minutes but never did.

First tech had me change settings to permit SMB1 communications, despite dire warnings from my NAS saying that it was not secure. The tech said that it was necessary. Ended call when my library was indexing after being re-added.

But the problem didn’t resolve--same error.

Called again. Second tech took my information, looked up case, gave me same advice. When I said I had done all of that, the tech said they’d call me back because they were having technical difficulties, but then never did. Both techs were kind and helpful, but nothing solved.

So I’m here. Any advice on the current state of things? Should things work with SMB2/3? Do I have to go back to SMB1 and take some additional steps? But, if that’s the case, is it safe to run with SMB1? 

Right now, I’ve reverted to my older settings (SMB2/3)  because the protocol changes the techs suggested messed up my Time Machine backups to the NAS.

Thanks in advance--hopefully I can get this solved. I have an extensive lossless iTunes library; streaming doesn't cut it for me. If I have to revert to SMB1, that’s also noxious--in addition to potentially being insecure, it looks like I’d have to choose between streaming my music or doing time machine backups to my NAS.


Best answer by Corry P 12 September 2022, 17:34

View original

19 replies

Which version of the Sonos software are you using? That will determine which versions of SMB you can use.


S1 still requires SMB v1 and NTML v1.


S2 can accept SMB v2 and SMB V3.


There are dozens of threads on this already. Most include potential solutions for S1, outside of Sonos’ software. 

Badge +1

I’m using the S2 software--sorry, should have specified.  That’s why I thought I could use SMB2/3.

As you mention, there have been a lot of threads on this, but it was hard for me to identify what the most recent information was. 

But, my initial read after doing my research was that I SHOULD be okay since I was using S2. If that’s correct, is something else causing the error? Any ideas? Here’s a full version of the error message…

9/8/22, 5:45 PM
Unable to play '06 Back In Black.m4a' - the file //ds718/music/Volumes/Music/iTunes/iTunes Media/Music/AC_DC/Back In Black/06 Back In Black.m4a cannot be found.

Thanks, knowing you’re using S2 helps, and yes, you should be fine using SMB 2 or SMB3.

There’s a couple of potential things that I, not an expert, would be looking at. First, I’d make sure that the folder where the data is was set with appropriate permissions. i.e. it’s the speaker that’s trying to access that data, not your computer. It’s entirely possible that an update of some sort changed the permissions on that folder, and the Sonos system is unable to “reach” that location via SMB. Folder permissions can be challenging, especially because many people don’t understand that it’s not the Sonos application on their controller device, but the Sonos software on the speaker that’s reaching out via SMB. And, of course, sometimes background updates can actually change sharing permissions. 

But second, if that doesn’t work, I’d try to play a song to generate that error, then I’d submit a system diagnostic within 10 minutes, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

Badge +1

Thanks again. Freed from the concern about SMB1/2/3, I have started looking at the permissions issues. But I still haven’t been able to solve the problem.

I thought I had all permissions set up correctly -- I have a unique user on my NAS titled “Sonos” that has read only access to the NAS music folder. When I point Sonos to use the folder as its music library, it requires the user and password before indexing (and I know I’m logging in because, once during the troubleshooting process, I typed the password wrong and it was rejected).

But, just to be sure, I’ve taken the following steps. First, I deleted the Sonos user from the NAS and recreated it. Next, I set up the music library from my iPhone instead of my Mac. Finally, I set up the music library by logging in--instead of as Sonos--as my admin login that has full permissions for every folder. 

Sadly, nothing has changed. Same error every time.

Anyone have ideas on what to try next? I'm at a loss. Is this a Sonos problem? A Synology problem? An Apple problem? User error because I messed something up while updating software or changing my iTunes settings?

Two Sonos related thoughts though. First, I’m glad they solved the SMB issues. Reading some of the old posts, I cringed when reading about how long it took for Sonos to move on from SMB1. Second, I did provide Sonos customer support with a system diagnostic--both techs were convinced that I need to revert my system to SMB1. But maybe they didn’t look deep enough...I might try them again next time I have the time at home to give them a call... 

Userlevel 7
Badge +18

Hi @Subarctic Crawdaddy 

Welcome to the Sonos Community!

Please try adding write access for the Sonos user on your NAS drive to your music folder (and apply to all sub-folders and contained files). Although this shouldn’t be needed, I have seen it help in the past when all else fails. The errors reported in your diagnostics are “Access Denied”, though as indexing works it’s clearly not just the password that’s the issue. Even with write access enabled, Sonos will not alter your files or folders in any way.

I hope this helps.

Badge +1

Corry P - thank your reply. I actually had tried that once before, and I just tried it again. No success. It’s interesting that it’s an “Access Denied” problem. One of the troubleshooting steps I took was to log into the NAS, not as “Sonos” (my custom user), but with my administrator login. Since my administrator login has complete access to all files on the NAS, I’m not sure why it would have been denied access.

I have had a busy week, and haven’t been able to try much else. But my next step is going to be to move my iTunes files off the server to an external hard drive, erase the entire iTunes folder and delete the Sonos login, and then build the folder from scratch and re-create the login. I hope to be able to try this sometime this week.

If there’s a simpler step to try before that, I’m open to suggestions. 

Userlevel 7
Badge +18

Hi @Subarctic Crawdaddy 

I would recommend instead just copying a single album folder to a new folder on the NAS and pointing Sonos to that new folder - the test would be the same as what you described, but much quicker and simpler to achieve.

Failing that, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to perhaps trawl your NAS settings for something none of us have thought of yet.

I hope this helps.

Badge +1

Okay…this just gets weirder and weirder. 

I do plan to try the “single album/single folder” idea--just haven’t had the time. But today, I decided to delete and re-add the library one more time. I didn't do that after adding read/write access, and thought it might make a difference.

This time, when I tried to add the library, I was able to enter my login credentials, and then the library started to index, as it always has. But then I got an error that I have never seen before:

So...this time, I didn’t even get as far as I got before, when the library indexed but then I got error codes while trying to play from it.

I know the library exists and that it’s still in the same place--I can see it on my NAS and it’s still working fine when playing from my iMac (so at least I can still rock out on my iMac’s speakers. Sigh.)

No idea what changed. The only thing I can think of is that I ran a scrub on my NAS for periodic maintenance today and that my computer is currently backing up to my Time Machine on the NAS. But can’t see how either of those could make a difference, given that I can still play the library on the iMac. I also downloaded music today from the library to my iPhone--Sonos is the only point of failure.

I will hopefully have time this weekend to create a new, single album folder and give that a shot.

I have also been in touch with Sonos tech support, after my earlier interaction where I wasn't called back, I received a check-in email. I wrote back, explaining what’s going on, but have not gotten a response yet. 

Check to see if your NAS changed your SMB settings.

Your desktop being able to see the files makes no difference, since the Sonos is reaching out from the speakers, not from your desktop. If you’re running S1 on your Sonos, then your NAS must be running SMB v1 and NTML 1. 

It has been known in the past for firmware updates to the NAS to alter these settings. 

Badge +1

I don’t think that they’ve changed...I’m running S2, so SMB1 isn’t required. My max is set at SMB3 and the min is set at SMB2. Nothing else looks different to me. Is there anything else I should check?

Not that I could think of, offhand. It wasn’t clear from your first post which OS you were running on your Sonos system. 

You’ve double checked that the file permissions on the folder are open?

Beyond that, I’d be asking Sonos what errors are showing up in the diagnostic, assuming you ran it within 10 minutes of attempting the library index. 


Badge +1

Thanks. I should have made it clear that I was S2 in my initial post.

Permissions are all good…

My next step, until/unless Sonos gets back to me, is to try a new, single album folder--both on my NAS and on another external hard drive that I use. Hopefully I’ll have the time to give that a shot this weekend.

Did you get in touch with the technical support team, as suggested by the Sonos rep above?

Badge +1

I did, I talked with tech support before I created this thread. The folks where nice, but they couldn't help me. The first tech signed off when we thought we had solved the problem, while my library was indexing--but it didn’t work. The second tech had to hang up because she had a bad connection, and I never got a call back. I filled out a response to an email survey saying I still needed assistance, but haven’t been contacted yet.

Creating new folders from scratch is the last thing I can come up with to try; I’ll contact them again if that doesn't solve the problem (or at least doesn’t provide any insight). Hopefully I can try it tomorrow or Sunday. 

I did, I talked with tech support before I created this thread. The folks where nice, but they couldn't help me. The first tech signed off when we thought we had solved the problem, while my library was indexing--but it didn’t work. The second tech had to hang up because she had a bad connection, and I never got a call back. I filled out a response to an email survey saying I still needed assistance, but haven’t been contacted yet.

Creating new folders from scratch is the last thing I can come up with to try; I’ll contact them again if that doesn't solve the problem (or at least doesn’t provide any insight). Hopefully I can try it tomorrow or Sunday. 

Do the settings mentioned in this thread perhaps help you - I think SMBv2 is being used in this instance min & max …


Badge +1, I created a new folder on my NAS, titled NAS Sonos, added a few albums--and it worked! 

Something has to be wrong with the iTunes NAS folder. Maybe iTunes did something that messed with it? Not sure what it could be.

Anyhow, that’s progress at least!

Not sure what my next step is going to be, I need to think on it and would happily entertain any suggestions. Some ideas:

  1. Copy over the iTunes folders to my external HD temporarily, nuke the iTunes folder on the NAS, and then copy it all back into a new folder. Cross fingers that this solves problem. 
  2. Move all of my iTunes music to the new NAS Sonos folder, then move the iTunes database to the external hard drive and keep iTunes located there (there is enough room). Nuke old iTunes folder on NAS. This keeps things separate, so there’s no potential interference with iTunes causing problem with Sonos. I would loose the imported iTunes playlists, but that’s not a big deal--I don't have many mixes, I  almost always play straight up albums. This would also de-link the two music sets, but that’s not a huge deal for me either.
  3. Keep iTunes where it is, and move copies of albums to the new NAS folder. Doubles up music on NAS, and begins to push the NAS on storage (I have a LOT of music). Still has other disadvantages of 2 above.
  4. Keep everything exactly where it is and keep trying to solve the problem. Not sure what I’d try next though. I gave the exact same access permissions to the new folder that Sonos had to the iTunes folder, and no other settings on my NAS have been changed.
Badge +1

One more update...I took a close look at the “Music” folder on my NAS (where iTunes lived, and realized it has an odd structure. Beneath the “Music” folder lives “iTunes.” Within “iTunes” there, is an iTunes Library file and a number of subfolders--including a “Music” subfolder where most of my music lives.

But, on this same level, there’s also folders titled “iTunes Music” (which contains nothing) and “iTunes Media” (which has further suborders, including another “Music” folder with a handful of albums in it. I’m not really sure how or why iTunes (uh….I’m sorry, Apple Music now) created a folder structure like this, but it seems a mess.

Previously, I was pointing Sonos to the “iTunes” folder right beneath the top level “Music.” Except for the weird speed-bump yesterday (really not sure what was going on there...), this is where I was getting the library indexing buy the “not found” errors when trying to play the playlists.

So, just to mess around, I pointed Sonos to the “Music” sub folder folder right beneath the “iTunes” folder, which is where most of my music seems to live. That worked, in so much as I can now play all of the albums in that folder (the vast majority of them)--just without the imported iTunes playlists. 

I’ve also double checked, and I was still able to play music on my iMac via iTunes (uh...sorry, Apple Music). I’m assuming I’ll also still, therefore, be able to move music to my iPhone.

Thoughts? Worst case, I can live with this--it will take me a little longer to find what I’m looking for on Sonos, but at least I have access to nearly all of my music. Ideally, I would like my imported playlists back, but I’ll survive without them if this is the best I can do.

@Subarctic Crawdaddy,

I assume there’s no rush here, so I would personally choose to be slightly cautious and opt for two separate steps, copy the library folders in small batches to the external HDD (as a separate backup) and then also move the folders to the new folder on the NAS and test all continue to work at various stages within the new shared folder on the NAS. 

When all have each transferred to the external HDD and new NAS folder, and you’re happy the library is still working in Sonos, I would then delete the original (now empty) library folder, check that the drive is error free with whatever tools/software you have available to do that …and then (if you prefer) try renaming the new folder to the original/preferred folder name and see if it continues to work when you change all to that new path and have re-indexed the library. This might also get your playlists working again too.

The copy of the library stored on the external HDD will surely be helpful too, as a backup of any music library is always a good thing. 

I have my own library backed up to another NAS and it is on a separate HDD which is lodged off-site at my Brothers Home, as I would hate to lose any of it, through disk failure, fire, theft etc.

@Subarctic Crawdaddy,

Note my last post was in reply to your earlier post about copying your music to the new NAS folder, but I see now from your later post, you have discovered you were pointing to the hierarchical ‘iTunes Music’ folder. rather than the actual  ‘Music’ folder (containing your music library) within the iTunes library folder structure… so I assume you do not need to copy things to the new NAS folder now … but I would still perhaps go on later to consider making a backup of your library elsewhere, as one day you may find such a backup useful.