Answered

new wifi router; now existing Sonos won’t connect

  • 12 October 2019
  • 8 replies
  • 213 views

Badge
Got a new router, now existing Sonos won’t connect. Can’t find where to change password in Sonos
icon

Best answer by ratty 12 October 2019, 19:51

View original

8 replies

https://support.sonos.com/s/global-search/new%20router

Nothing is working to connect to our new Wi-Fi router.  What can we do?

Nothing is working to connect to our new Wi-Fi router.  What can we do?

Cable just one Sonos device to the new router and power it on. 

Power on the other Sonos devices, one at a time, giving each time to boot and settle, before moving onto the next.

Open the Sonos App on a compatible mobile device, connected to the new routers WiFi, to see that all Speakers are present and correct.

Goto the App “Settings/System/Network/Wireless Setup” and enter the new routers WiFi credentials (case sensitive) for the 2.4ghz band.

Uncable the Sonos device from the router and move it back to where you want it and all devices will now run on your new routers WiFi.

 

**Whatever you do, do NOT factory reset your Sonos devices, it is often unnecessary and in some circumstances, you could end up losing the entire original Sonos setup.

Isn’t that the same information that’s in the link that ratty provided?

Isn’t that the same information that’s in the link that ratty provided?

I just summarised things in an attempt to (hopefully) try to assist sdarmody a little further, as clearly @ratty’s link was already there in place, but they still appear to be having some difficulties getting their Sonos system back up and running on their new WiFi. I was hoping a short summary might help them out .

Hi all, I’m having the same issues. NOTHING was working, so I reset the app (deleted and reinstalled on my phone).  NOW, there is not way for me to select settings from the app.  my only choices are to start a  new system or connect to an existing.  Neither of these will work

 

alie789,

 

After replacing a router, your first action should be to reboot EVERYTHING. Don’t factory reset your SONOS system without further consult. 

Hi all, I’m having the same issues. NOTHING was working, so I reset the app (deleted and reinstalled on my phone).  NOW, there is not way for me to select settings from the app.  my only choices are to start a  new system or connect to an existing.  Neither of these will work

That’s not actually the position... if you choose to reset your Sonos App, having changed router, all you need do is cable any Sonos speaker or device from your existing setup, to the new router using an Ethernet cable. Leave all other Sonos Speakers/devices switched off for now. 

With your compatible mobile connected to the new routers WiFi network, open the Sonos App and choose the option to connect to the 'existing’ Sonos system… your cabled Sonos speaker will reappear in the App, that’s providing you have not factory reset your devices.

Please make sure you do not create a new Sonos system.

As you power on each of your other Sonos devices they will reappear in the App. When all devices are present and correct, then see my earlier post of what you then need to do after that.

 

Reply