Answered

iPhone not connecting to sonos but iPad, iMac and fire table are connecting

  • 18 December 2018
  • 18 replies
  • 4990 views

Hi

I get this issue on and off every couple of weeks when my iPhone won't connect to my sonos system

My iPad, iMac and fire tablet all work fine

i have removed the sonos app on the iPhone and re installed and still not working. re booted iphone, disconnected the wifi etc after a few days it normally reconnects


any ideas??
icon

Best answer by Keith N 28 December 2018, 15:39

At this point, it might be best to give our support team a call. There is something on the network that is getting between your iPhone and Sonos. I've seen similar cases before, but in those situations, it ended up being the controller (your iPhone in this case) connecting to a similarly named network or an extender that isn't configured properly.



Either way, I believe having a technician get a closer look at your specific network in real-time would be the best (and fastest) way to get this sorted.
View original

18 replies

Userlevel 7
Badge +19
Hello, gboi. If the problem is only on your iPhone, that tells us that the problem isn't necessarily the Sonos system itself but rather the controller app (on your iPhone) trying to talk to Sonos. That being said, what is the iOS version you are running? When the error occurs, do you get an error message or does the Sonos system simply disappear on the iPhone? Additionally, does the phone lose all internet connectivity or does it only drop Sonos?
IOS 12, iPad on same system.

It won’t find existing system at all. No error messages. All other apps and internet work fine
Userlevel 7
Badge +19
Understood. The tricky part here is that other devices on the same network are not having this same problem. Would you mind submitting a diagnostic report after reproducing the problem? Be sure to reply here with the confirmation number it gives at the end. I'm curious to see if there are any internal errors will show up.

Thanks!
It currently won’t give me the option to submit diagnostics report as it can’t find existing sonos system. As soon as it’s online again I will

Thanks
So tonight it has finally connected to iPhone

Diagnostics 682610474
Userlevel 7
Badge +22
On ios devices it is normally an issue with the router hanging on to 2 different IP addresses for ios device after an ios update.

Easiest way to clear up is to go into phone settings, forget home network, reboot phone and router, add back home wifi to home network. This almost always clears up any lingering networking issues between the iPhone and router.

Its not an actual Sonos issue but Sonos not connecting is a symptom.
if it was an ip issue with ios I would expect it to happen to all ios devices. iPad and another iPhone attached fine to the sonos system.

If I keep rebooting the router to get the sonos system to work this will eventually start reducing my fibre speed as it will think there is a connection issue so would rather not keep having to reboot router unnecessarily.

I may look to setting up a mesh system and see if the issue continues.
It’s happened again! Diagnostics 1450695835

Don’t know why this keeps happening
It’s happened again! Diagnostics 1450695835

Don’t know why this keeps happening

What router and WiFi system are you using? Are you using any wifi network extenders/repeaters etc?
TalkTalk hub. The newest one. The only extender is a power line but they is only Ethernet connection no WiFi. It’s strange the app works fine on all other devices just not my main iPhone

Thanks
Userlevel 7
Badge +19
At this point, it might be best to give our support team a call. There is something on the network that is getting between your iPhone and Sonos. I've seen similar cases before, but in those situations, it ended up being the controller (your iPhone in this case) connecting to a similarly named network or an extender that isn't configured properly.

Either way, I believe having a technician get a closer look at your specific network in real-time would be the best (and fastest) way to get this sorted.
Badge
I have exactly the same problem. I’ve followed the suggestions here several times. I’ve also reset the controller on my phone several times. I go through the process of finding the Sonos system on my network, pressing the play and volume buttons on the nearest speaker and my phone says connected. Then when it attempts to connect, it goes back to the error message.
Userlevel 7
Badge +20
What do you mean by re-setting the controller on your phone? What phone and OS are you using?

Have you tried deleting the App and re-installing then select connect to existing system.

I have the same problem - it drives me nuts. My Phone keeps losing the connection (so does my wife’s). I also get odd scenarios where only 1-2 of my speakers connect and not all as well as periodically I will see all the speakers and then when I try to play something it decides it won’t connect. Every time I need to go back to my desktop and control from there.

I follow all the guidance as above (and have done many times) to get a new IP address as well as sometimes lock IPs in for my phone. None of these attempts stabilise the issues or have helped over the past 12 months I’ve had this set-up.

looks like I just need to call Sonos directly an gos through trouble shooting?

 

That would be my suggestion. 

Try to disable location services on your ipad/iPhone while connecting.

 

 

Userlevel 7
Badge +21

Make sure your iPhone does NOT have a VPN set on it, as these will often interfere with local network connectivity. If you use your phone to connect to your corporate network, chances are good that you have a VPN on there.

Forget wi fi network.  Reboot phone and join network.  It works. 

Reply