Answered

Connection Problems Since S2

  • 20 February 2021
  • 5 replies
  • 152 views

Prior to the S2 app I had no problems.   Since that app upgrade I have routine connection issues.  I have called tech support multiple times and they say the speakers are connected to the system fine, so I’m convinced it’s comm between the phone and the system.  We have an EERO mesh system in the house for WiFi.   We have a lot of speakers.  On the order of 20. I am running a boost controller and we are using IPhone 11’s to communicate with the system.  This issue can be very sporadic.  This morning I was getting the cannot connect message and the 10 minutes later it connected fine.  Then 5 minutes later no connect.  Sometimes it only shows my move speakers and then later they all show up.  I’m running the latest IOS version on the phones and everything is up to date.  This I very frustrating after spending thousands to not be able to use the system.  Any help is much appreciated.  

icon

Best answer by Corry P 9 March 2021, 14:25

Hi @thompsdw 

Welcome to the Sonos Community!

Are you still having this issue? It’s likely caused by the main Eero mesh node acting as a router in addition to your main router - this means two devices are handing out IP addresses (running DHCP servers, in technical lingo) which results in you essentially having two networks.

To resolve this, please follow these instructions to configure the Eero mesh to operative in Bridge/AP mode: 

  • Open (after installing, if you don’t already have it) the Eero app and tap Settings (bottom right corner)
  • Tap Advanced
  • Tap DHCP & NAT
  • Switch your selection from Automatic (recommended) to Bridge or Manual (for those running static IP)
  • Tap the Save button in the top right corner

After doing these steps, I recommend you then reboot your main router to make sure all devices on your network refresh their connection and get an IP address from it, rather than use their old Eero-issued IP addresses.

View original

5 replies

So, the Eero mesh makes only a small amount of difference, since you are running in SonosNet mode, using the BOOST.

But small is not zero, so there are a couple of things to check.

First, I’d recommend reading the wifi interference FAQ. There are a couple of potentials explained there that are worth investigating. I’d also be sure to double check that the network channels for your Eero and your SonosNet are not the same. I’m not an Eero user, so I can’t tell you how to do it, but it is wise to lock down the whole ‘auto channel’ function it may have to just one, so you can then assure that SonosNet is on another one.

Second, I’d make sure that the BOOST is connected to the root Eero device, and not one of the satellite Eero devices. 

Unfortunately, and infrequently, the Sonos update process can expose a failure in the DHCP table of any router. Easily fixed (although in your and my case, somewhat a lengthy process, given the number of speakers) by unplugging all Sonos devices from power, and then, while they are unplugged, rebooting the router (the base, again, not one of the satellites). Only once the router comes back up should you plug back in the Sonos. Or, as a more permanent alternative, you could simply assign all your Sonos devices reserved IP addresses in your router’s software, which accomplishes the same thing, just more permanently.  
 

Thank you.  I don’t have it setup that way for a couple of reasons.   First reason is that the primary router is in the basement.  Second I only have two ports on the primary router.  One is used by the wireless inlet and the second goes to a network switch that distributes wireless over the home cat6 network.  What if it connected to the basement switch?

As long as it’s an unmanaged switch, from a network perspective, the BOOST should think it is connected directly to the primary router.

I’m a little confused over your statement ‘distributes wireless over the home cat6 network’. If it’s over cat6, it isn’t wireless, so it’s just the LAN. If, again, that switch in the basement is an unmanaged switch, the BOOST could be connected to any network drop that connects to that switch. Just not any of the Eero pucks.

Userlevel 5
Badge +15

Hi @thompsdw 

Welcome to the Sonos Community!

Are you still having this issue? It’s likely caused by the main Eero mesh node acting as a router in addition to your main router - this means two devices are handing out IP addresses (running DHCP servers, in technical lingo) which results in you essentially having two networks.

To resolve this, please follow these instructions to configure the Eero mesh to operative in Bridge/AP mode: 

  • Open (after installing, if you don’t already have it) the Eero app and tap Settings (bottom right corner)
  • Tap Advanced
  • Tap DHCP & NAT
  • Switch your selection from Automatic (recommended) to Bridge or Manual (for those running static IP)
  • Tap the Save button in the top right corner

After doing these steps, I recommend you then reboot your main router to make sure all devices on your network refresh their connection and get an IP address from it, rather than use their old Eero-issued IP addresses.

Well, I think I figured out the problem this morning with EERO tech support.  Evidently the switches I am using are a managed switch.  I was certain that they were unmanaged, but when I sent the pictures of the models of the switches to the EERO team they looked up the specs and determined that they were managed.  UGH.  I should have taken the time to dig a little deeper on this one and appreciate all the support, but it’s nice to have a direction that will resolve multiple issues.

Reply