Question

Cant add devices as says controller needs updating

  • 23 October 2016
  • 3 replies
  • 494 views

This is Android version, Pixel XL phone, App version 6.4.7

I'm trying to add new devices to existing setup, but each time i select add new Player or Sub it takes me to a screen that says Sonos App needs updating - it then takes me play store which shows the sonos app page, but only says Open as i've already got the current version.

Have tried uninstalling, and re-installing but same, have reset app, but same.

Seems i'm currently unable to add any new devices - not happy !!

😠

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +21
Go into your App and find "About my Sonos" and check that all units are at 6.4. The current app version is 6.4.7 so that is correct but it may be that some of your current units are out of date.


This link gives information about the latest version http://www.sonos.com/en-us/software/release/6-4
Most of the units should in fact be at 6.4.2, though probably not BOOST or BRIDGE.

Dean Barrett,

If you continue to be stuck in an update loop try removing and reinstalling the controller app. If that doesn't work, try "adding a BOOST or BRIDGE". Ignore the pictures and when prompted to push buttons press the play/pause and vol+ together (or the Join button for a SUB).
Badge +1
Hello Dean,

As Stuart has mentioned, the current Sonos application version is 6.4.7, and there should not be an update available on the Android.

After opening the Sonos application and heading to the “Add a Player or SUB” section, follow the link to the Play Store, and then press the “Open” button. Once the Sonos application opens, try using the “Add a Player or SUB” again to see if the problem continues. This will let us know if there are two Sonos apps installed on the Android.

If the problem continues, mind submitting a diagnostic from your Sonos system and replying back with your confirmation number?