YouTube music still not working!!

  • 28 September 2020
  • 19 replies
  • 8499 views

Userlevel 1

So I got a bunch of IKEA Sonos Speakers and I can simply not use them. The software is a huge big bug.

How do you guys get you speakers to play anything at all, let alone the song you wish at the speaker you wish?

Why is it after 7months STILL not possible to sync a premium youtube account to Sonos, it keeps asking for a premium account!!!

Silly silly software, this is a shame as the speakers are of descent quality for the price. With the small hitch you can not use them.

 

I’ve sent many many buy reports via the app, registers for beta program, keep asking for support but no, filled out many many of these feedback sheets about things not working, nothing all quiet not a beep from Sonos.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

19 replies

Sonos, Please stop blaming the content holders! I can use voice command on my phone and stream free music content from YouTube (not Premium) from my Android Phone to any Bluetooth enabled speaker. I was able to stream YouTube (standard free content with adds) to my Sonos for the last 7 years. Then...I upgraded to a boost (replaced the Bridge) and the S2 app. Result = Broken. No more standard YouTube through SONOS. All voice command to play anything via YouTube on the basic free access is no longer working and nothing I do restores that. Looks like it's back to Bluetooth speaker solutions if I want any content outside of my own SONOS library.

Userlevel 1

So the end have come. Even though working with development in a company connected to Sonos having our contact asking them to connect to me I heard nothing. This is so poor and the speakers do not work. guys in the beta program are annoyed beyond too. Simply not working. This evening I took the decision to throw my setup out the door ordering other speakers capable of google assistant and Bluetooth connection.

It’s simply so bad from Sonos I can not find words. Why even bother with a feedback loop when its a dead end where no one responds.

 

Ta ta…. over and out!!!!

 

*Moderator Note: Modified in accordance with the Community Code of Conduct.*

 
 
 
 
 
Userlevel 7
Badge +23

I see a LOT OD arguing about philosophy here. Basically the FAULT IS SONOS PERIOD!!!

Uoutube was here and SONOS GET A *%*clue. You have consumers about to ditch product because you are *  them on service

I have cancelled my Sonos complete system order ($2775) u til this is fixed or I get another system that doesn’t screw with me  sick of SONOS *nonsense

 

FIX IT *Please

 

  • Moderator edited to conform with community terms and conditions.

This is 100% googles problem to solve. If you think otherwise, then you are the you-know-what.

I see a LOT OD arguing about philosophy here. Basically the FAULT IS SONOS PERIOD!!!

Uoutube was here and SONOS GET A *%*clue. You have consumers about to ditch product because you are * them on service

I have cancelled my Sonos complete system order ($2775) u til this is fixed or I get another system that doesn’t screw with me  sick of SONOS *nonsense

 

FIX IT *Please

 

  • Moderator edited to conform with community terms and conditions.
Userlevel 7
Badge +23

I agree. Great speakers, atrocious software, negligible customer service.


I agree, Google’s software here (the YTM SMAPI service specifically) is atrocious. I doubt Google care enough to fix it though. The Sonos software on the other hand is of a very high quality.

Badge +1

I agree. Great speakers, atrocious software, negligible customer service. I have four of the speakers. I will buy no more until they sort themselves out.

I have premium YTM as it replaces Google Play. Sonos need to sort their s<>t our or they can refund the speakers.

Hi

I’ve tried to read through all the threads regarding YTM but can’t see my problem. I do not have a premium TYM account but do use it for listening to.

Weirdly when doing so on my iPhone I get the icon up to use bluetooth and just link in straight to my Sonos.

However, when doing the same thing from my Windows PC that option is not available.

 

Thanks for any helpful comments.

Userlevel 7
Badge +23

You are complaining about YouTube Video, which is a Google company. Google are the biggest ad company on the planet.

You need to add iBroadcast to your Sonos system, just like you did YTM: Settings / Services / Add Service.

I’m sick of saying this, but I’m going to anyway: this is not a Sonos problem to solve, it is Google’s, but they have zero interest in doing so.

Userlevel 1

@Superhero Have you tried contacting Sonos about this by phone?

No, why would I do that? Do you really think that would help? coming to a girl in a call center who couldn’t care less and by best following her Q+A flow chart.  

YTM is pretty terrible at their Sonos integration with few signs of improvement. Stop using an ad company for your music, try iBroadcast instead.

So what is this ad company thingy? How would you recon I can come around this with sonos? Any other system you can stream from whatever device you like from any app, but not Sonos. They are locked to their app and it’s not working!!

I downloaded iBroadcast per your suggestion and there was no way to make the sound go to Sonos. Google popped up directly though and I could cast to my google speakers.  Sonos not a sign…..

 

Sonos still useless! Sonos still no response from their support!

 

Userlevel 7
Badge +23

YTM is pretty terrible at their Sonos integration with few signs of improvement. Stop using an ad company for your music, try iBroadcast instead.

No. I have not tried by phone. Any other way have been useless, with Sonos usually trying to blame YouTube. 

Userlevel 7
Badge +17

@Superhero Have you tried contacting Sonos about this by phone?

In YouTube music it shows my Playlists, and the songs in them, but then says I am not allowed to play any. Pretty annoying that Sonos simply says it's a YouTube problem. It is not. If Youtube Music can't be played in Sonos, then it's the speakers the ones who become useless. 

Userlevel 1

Still noting, still not connecting with YTM with the right account. Also the desktop forced me to the new app making it impossible to play from that one too.

 

*great* Sonos, great!

Userlevel 1

https://en.community.sonos.com/controllers-software-228995/youtube-music-controller-issues-6825376

 

No action from Sonos. No replies to feedback, no nothing. Really bad. I do work with development in the same segment where the team advised me to send Sonos feedback from the app when its not working, when it’s lagging etc. But nothing!

I find is so mega strange.

 

I go to a gym in the mornings, they got a bunch of Sonos 1 speakers there too playing web radio. Same there, music comes from random speakers, suddenly stopping so you have to press play again etc etc.  

 

Seems so strange a company like Sonos can not get stuff to work. And for sure, there must be users that are happy too as it’s profiled as premium speakers with a price tag to come with that too.

 

 

 

All my system has worked perfectly for 9 years. Sorry that your experience has been bad.

I don't really understand what your account situation is, but I haven't seen any similar issues raised on this forum.  I will hazard a guess that YTM is working for 99.9% of users.

I cannot comment on the quality of integration into Sonos.

Userlevel 1

To the best of my knowledge YTM is working fine on Sonos. Maybe this will help

https://support.sonos.com/s/article/3259?language=en_US

 

Thanks for trying to help. But it’s not working. Back in the days youtube was a standalone service, then google came and merged G with YT. So now my YT account has two users. I can not choose the user I use only the other one with no playlists what so ever.

 

In the YTM app it’s a non issue working flawless, but I can not beam my music from there to Sonos……

Even when choosing this starting from scratch user account It’s sooooo hard to search for songs. In the YT app, just search and go, in Sonos it’s made close to impossible!

 

This is so bad! Also forced to the S2 app that is even worse than the S1 was…. gaaaaah.

 

A good start would be to fix this silly bug and let me att my PREMIUM account….   Sigh.

 

Spotify has this normal link to play stuff on Sonos, so atleast that part works, then we have this whole issue with lagging, playing different song on all speakers randomly activating or muting speakers so it still not a solution to switch to Spotify.  again gaaaaah

To the best of my knowledge YTM is working fine on Sonos. Maybe this will help

https://support.sonos.com/s/article/3259?language=en_US

It may be worth checking that your location is correct on your Sonos profile and matches where your YTM account is registered. That is a common source of error with streaming services.