with new S2 app I get stuck in "not connected"

  • 10 December 2022
  • 2 replies

Userlevel 2
Badge +6

Recently the iOS S2 controller app was updated. In the past if a device was unplugged, it just didn’t show up. Then when you plugged it in it would be found. It was like this for ages, with S1 also.

Now if you unplug a device it shows up as “not connected”, and even if you plug it back in it remains “not connected”. There is now a lengthy process to re-connect.

Luckily for me, for now, the S2 controller on the PC still works the old way – I can unplug and re-plug. To add insult to injury, it also says it can’t find a Sonos Connect. Well, I decommissioned that a year ago, and of course it isn’t supported by S2 anyway. The fact that it spends many minutes trying to reconnect to it is annoying

I went to the web page, and it listed all my devices correctly, but said they all needed to be update to make the S2 compatibly. But that is clearly not true either – I have used all my device with S2.

Regarding my main problem, the “not connected” when I turn something off. I know Sonos has always recommended you leave everything on all the time, but I really don’t want to. I have a port that I used at most once a month to digitize my turntable. And I have a remote SL1 that I used maybe once a week.

What’s going on? Is this just a temporary bug with the S2 iOS controller that will be fixed? Or starting now is it absolutely required that all Sonos devices be powered 24/7?

My home network has not changed, I have not update the router for quite a while.


Best answer by buzz 12 December 2022, 04:21

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 2
Badge +6

Here is a screen shot. The port is not-connected, because I turned it off. but the Connect is a device I don’t own any longer. In fact I already traded it in to get my port. Why is the controller still trying to “connect” it, and how can I get it to stop?


This is a new “feature” that still needs some work.

You may experience some relief it you go to Settings → App Preferences → Reset App. 

I’ve seen other users report a much simpler notification that can easily be ignored.