Why will m4a not play?

I have an m4a that won’t play, even though it seems to adhere to Sonos’ supported file formats. Here is some more information about the file:

Codec: AAC LC
Sample rate: 32 kHz

The error message I am getting is: “The song is not encoded correctly”. It plays without any issues on other devices.

Why doesn’t it work on Sonos?


Best answer by Corry P 7 June 2022, 11:17

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

The link you posted is for online streaming service developers. The relevant article for local music is here

I’m not entirely sure that AAC-LC is supported for local files. Playback of local libraries was the original music source when Sonos first started but isn’t receiving nearly as much attention these days, as it’s become rather a minority interest compared to online streaming. 

If you have only a few AAC-LC files the simplest option would be to run them through a converter.

Thanks, @ratty. Actually I am working on an online streaming service and I get the same error when trying to stream it from a server. Tried it locally and that doesn’t work either.

Userlevel 7

@mischa78 What is the bitrate of the AAC files?

@GuitarSuperstar below is the mediainfo output about the file I am trying to play. It mentions different bit rates, but overall bit rate seems to be 127kbps. Do you see anything here that could explain my issue?

Complete name                            : test/test.m4a
Format                                   : MPEG-4
Format profile                           : Base Media / Version 2
Codec ID                                 : mp42 (isom/mp42)
File size                                : 56.5 MiB
Duration                                 : 1 h 2 min
Overall bit rate mode                    : Variable
Overall bit rate                         : 127 kb/s
Encoded date                             : UTC 2022-05-22 00:17:14
Tagged date                              : UTC 2022-05-22 00:17:14

ID                                       : 1
Format                                   : AAC LC
Format/Info                              : Advanced Audio Codec Low Complexity
Codec ID                                 : mp4a-40-2
Duration                                 : 1 h 2 min
Bit rate mode                            : Variable
Bit rate                                 : 126 kb/s
Maximum bit rate                         : 159 kb/s
Channel(s)                               : 1 channel
Channel layout                           : C
Sampling rate                            : 32.0 kHz
Frame rate                               : 31.250 FPS (1024 SPF)
Compression mode                         : Lossy
Stream size                              : 56.0 MiB (99%)
Title                                    : AAC audio
Encoded date                             : UTC 2022-05-22 00:17:14
Tagged date                              : UTC 2022-05-22 00:17:14


Badge +20

The length (time wise) could very well be the issue, can you try with a much shorter length version say 10 mins?

@Belly M unfortunately shorter files do not work either

Could the issue be that variable bit rate mode?

Userlevel 7
Badge +18

Hi @mischa78 

Welcome to the Sonos Community!

Variable bitrate won’t be the problem. Nor do I see any particular problem with the file details, and AAC should play from a local source.

All I can think of as to why it won’t play is if it’s an unusual implementation of the AAC codec - though I don’t know if such things exist.

I’m with @ratty on this one - converting the files to a different codec might be the way to go. Considering the file properties, it sure wouldn’t take long on a modern computer. 

Another thing to test would be to take a file in another format that does play and convert it to have the same properties as the file above. Ideally, do it in different software than was used to create the file above. If it plays, then maybe the other software is doing something unusual. If it doesn’t play, convert again, changing one property of the file and test. Keep changing properties until you find what caused the problem, and avoid that when converting/creating new files.

Are you able to play other files from the same folder?

I hope this helps.