Unable to see media files on NAS running Plex Media Server

  • 27 July 2021
  • 6 replies

Userlevel 1



I configured Plex on my QNAP NAS and of course I made the server remotely accessible.

I added the Plex service to my Sonos but the only things I see are public media.

My personal music library is not visible.

What’s wrong?





Best answer by maxmonz 30 July 2021, 17:16

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Are you able to see your personal library through the Plex app on your phone when not connected to your WiFi?  The issue is most likely with your local network settings, and although some here might be able to assist, you might find better help with Plex support.

Userlevel 7
Badge +18

Hi @maxmonz 

Welcome to the Sonos Community!

I too have Plex and if I recall correctly, I had the same problem. It turned out that I had to give both Plex and Sonos both read and write permissions to the music folder, and all subfolders and contained files.

I hope this helps.

Edit: It was probably more about the Plex permissions, thinking about it.

Userlevel 1

Hi Corry,

what you mean by “give read and write permissions to Sonos and Plex”?

Plex is the server running on NAS and of course can read file from music folders in order to creata a music library.

Sonos is not suppose to know anything about folder permissions and for sure is not suppose to have write access. It should see music files through the Plex server exactly like my smart TV see files thanks to DLNA. This is what, in my opinion, a media server should do.

I know I could play music on my Sonos sharing folders through Samba protocol but Samba protocol is ridiculous as ridiculous is that Sonos can only play music on local network this way. Why not using DLNA? Sonos app recognize the DLNA server of my NAS and let me navigate through folders but it refuses to play. It’s crazy. 

So my opinion is Plex service on Sonos app has problems.

Userlevel 7
Badge +18

Hi @maxmonz 

I can’t say for sure what you’ll need to do as my NAS is a Pi running Linux and I just used the CHMOD 664 command to alter file/folder permissions for the user that the Plex service utilises. Your system is different as you are using QNAP - I can’t assist you with that. All I can say is I had a similar problem, and that was what fixed it. If the Plex software is included on your QNAP device, then it’s likely QNAP will be able to assist - but it would also be more likely that you don’t need to adjust any permissions at all.

You are correct about Sonos not needing permissions - this is why I edited my earlier post. Plex should bypass this for Sonos, and I believe I only needed to allow permissions for both because I also use the Sonos Music Library pointing to the same path as Plex, so I have 2 ways of accessing the same folder (not needed for the average user but for facilitating technical support). I knew that Sonos needs rw permissions over SMB, and guessed that Plex might as well (at least when serving to Sonos). I changed the permissions and Plex worked on Sonos. 

As @melvimbe mentioned, it could be a Plex configuration issue, though I can’t think of any relevant settings myself. Or it could be that QNAP support is the best way to go (not for Sonos playback, but on how to adjust permissions).

A reboot of the NAS, Sonos and your router may also help.

A final thought - is your Plex server/QNAP on the same subnet as Sonos? It should be, I believe. If not, you may need to set up remote access in the Plex Server settings, or reconfigure it to be on the same subnet.


Userlevel 1


I solved the problem. It was easier than all we have supposed. When I opened the port on my router I forgot I have two routers and so I need a double NAT.

Now it works.

Thanks anyway for all.


Userlevel 7
Badge +18

Hi @maxmonz 

Thanks for updating us! And, I’m glad you found an answer.

I guess my theory about the subnet wasn’t far off!

Enjoy the tunes!