Unable to add Plex service to Sonos app on Android

  • 20 November 2022
  • 8 replies



My wife’s phone has been chronically unable to connect reliably to our One SL. I read that one possible solution was to remove and re-add the Plex service in the Sonos app, so I removed Plex as a service and attempted to add it back. 

Under “Services & Voice” I tap “Add a Service” and choose Plex from the list. I tap “Add to Sonos” on the next screen. I already have an account (with PlexPass) so I tap that, then tap “Authorize” on the next page. This takes me to the (IP Address) would like to sign in to your plex account page. I tap “sign in” and am greeted with the message “Thanks! You have successfully signed in. You may now close this window.”

When I go back to the Sonos screen, the screen now reads:


“Connection Error

There was a problem adding the Plex account. 

A connection to Plex could not be made.”


I verify within my plex account that the device has been authorized. In this case it’s been added about 15 times because it keeps failing. But it’s there in Plex as “Plex for Sonos 3.0.0.” 

Any thoughts on what I can do to successfully add the account? I remember this happening when I first added the plex service, first to my phone and then to hers. But I can’t remember how I finally got it to work. I’ve tried clearing the cache on the sonos app on her phone, but that hasn’t helped.

FWIW, I’d prefer to use the Plexamp app to stream music to the One SL because I prefer the interface and ease of getting to the album I’d like to play, but that’s been a nightmare in and of itself -- can’t ever get Plexamp to play more than one song at a time before disconnecting from the speaker, but that’s an issue for a different forum.

I did search the forums before posting, and was unable to find anybody else having the same issue with the app. Thanks in advance,




Best answer by 106rallye 20 November 2022, 10:21

View original

8 replies

Userlevel 7
Badge +17

You do not ad Plex to the app, you ad it to the system via the app. If adding it works on your phone, you should not have to ad it again with your wife’s phone. Remember: the app is just a fancy remote for the system.

My Plex sometimes loses the ability to play to outside sources. I have to toggle this option in Plex on my NAS. Your error message does, to me, seem to point to a fault like that and not an authorization fault.

Pat : any luck on getting this resolved? I have exactly the same issue trying to play plexamp on Sonos. Plays the first song (after an initial stutter) then refuses to play any more until I disconnect & then reconnect.  I've been suffering with this issue for months but have been ignoring it as fortunately I have Google speakers too. Annoying though. 

Userlevel 7
Badge +18

Hi @icnsid3 

Welcome to the Sonos Community!

I can only recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.


106rallye nailed it... I wasn't clear on the fact that services meant all services on a given Sonos system, not just an individual device. Looks like the reason I couldn't add the service on my wife's phone is that it had already been added.

Now if I could just get Sonos to play nice with Plex... Even with the service installed, the system will frequently stop playing after one or two songs (just like the problem you're experiencing Praenei), regardless of whether I play from the Sonos app or plexamp. Makes it almost unusable. Uninstalling and reinstalling the service, as suggested by numerous posts on this forum, hasn't been helpful (which is why I was in the situation I posted about in the first place). I've been dealing with it since I bought the Arc. Probably won't buy other Sonos products to add to the system until it's better addressed, either by Sonos or Plex.

Thanks for the help! 

Userlevel 7
Badge +18

Hi @icnsid3 

Please see my earlier post. Our technical support team are able to interrogate your speakers quite thoroughly and should be able to determine exactly what the issue is, and help you fix it. Quite likely, it’s just electromagnetic interference from other devices, or a poor WiFi signal strength. If other music sources don’t have the same issue (when playing similar bitrates), then something else may be the issue.

For what it’s worth, I play music via Plex (via Sonos app or Alexa - I can’t really speak for how the Plex app performs) on my own system and don’t experience any problems.


Thanks Corry. I’ve tried solving it myself multiple times using advice from the forums, but I’ll definitely contact tech support to see if they can help me resolve it. 

Much appreciated!


Hi Pat,

I contacted Sonos tech support on Friday & despite their best endeavours they couldn't find anything wrong. Playing Plex via the Alexa app on Sonos works for me but plexamp just pauses early on in the first song, starts again & then stops at the end of the first song. Please post back a solution here if you get anywhere.



Will do Praenei. Haven’t had a chance yet. I don’t use Alexa… the sonos app itself has usually worked for me but hasn’t been recently. Hopefully I’ll get to contact them this week.