Unable to add music library from USB drive connected to WiFi Router


I am trying to add a music library from a USB hard drive connected to my Router but have had no success. I would like to play music from my library without leaving my PC on all of the time.

I have a TP Link AX55 Router. My PC is running Windows 10 Pro. My Sonos system is running the S2 app. I have mapped the hard drive as a network drive and it shows in Windows Explorer as G (\\TPShared) (G:). I am able to browse the drive and copy files in and out through Windows Explorer.

I have searched through previous posts but still don’t know if it can be done or not. Am I correct in assuming that because I am using the S2 app, it uses SMB v2 which Sonos doesn’t support yet?

Any help would be greatly appreciated.



Best answer by S98765 7 October 2022, 11:13

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

I think you’re conflating up a couple of things. 

First, in order to use a USB drive, your router must treat it as an NAS. Check your router’s manual to see if it can actually do this. Not all/many routers can, as it requires extra programming and CPU power. Setting it up in windows as a mapped drive does nothing whatsoever for Sonos, when your windows is turned off,  as mapped drives require windows to be working in order for them to be accessed.

SMB is a connection method by which NAS drives are accessed. It would not be used for regular ‘mapped’ drive in windows, only a drive set up as an NAS. 

You may want to reference this FAQ as well. 

Userlevel 6
Badge +14

Here's the detail on setting up the usb as a samba drive:

Userlevel 5
Badge +9

Never yet been able to get Sonos to work with stock ASUS firmware - only works with Merlin's versions of the Firmware.


Er... the OP has TP-Link, not ASUS.

If the USB drive can be mapped and accessed from Windows the logical assumption is that SMB (Samba) is running on the router. With S2 it doesn’t matter whether it’s using SMB1 or SMB2/3. Sonos should still be able to access it. Just make sure the correct path is being used when adding the library. Usually the router config pages will tell you the path to use.



Thanks for the replies. Yes my router is a TP-Link brand. I think the model might also be known as the AX3000. Here are some screenshots of my router settings.



When I go to Music Library Settings, then Add Folder, then Networked Device (ex. NAS drive), I typed the path \\TPShared\Music. I then put in the username and password as per my router settings. I then get the following error message



Am I missing something?

Thanks again

Try //TPShared/volume1/Music (or \\TPShared\volume1\Music)

Thanks ratty. I tried that but got the following error


Userlevel 7
Badge +15

Before you try a thing Sonos related, I would connect to it through Windows explorer.  The path you use there will be the same as Sonos will need (as long as you're not mapping a drive to the Share on the PC).  It means you then at least know the path to use in Sonos and any errors are not Permissions related at that point.

For example, what do you see if you just type \\TPShared into the address bar in Explorer?

I think I have worked it out.

I tried \\TPShared\G\Music and it added with no errors. Thank you everyone for your expertise, your replies and your time.

Take it easy

Userlevel 7
Badge +15

Out of interest, what do you see if you just type \\TPShared into the address bar in Explorer?


Hi sjw,

When I type \\TPShared it directs to the Media Server location of the NAS.



This is the same as when I click on the TPShared media server in Network Locations in This PC. I have the Media Sharing setting enabled in the router settings. 

When I click on the G drive, it takes me to the folders that are on the USB drive.