unable to accept terms on use on Sonos App on iphone

Brand new user to Sonos. Downloaded the Sonos App to iPhone but was unable to use, as the button to accept terms of use button is greyed out. 
Have then downloaded Sonos App to iPad and been able to accept terms of use there and get started using new Sonos Roam. This is not ideal as wish to be able to use Sonos Roam when out of range of Wi-Fi in garden. 
Can anyone suggest fix to get the Sonos App working on iPhone so I can actually roam using my speaker. 
I have already checked/tried:

  • Checking I am on latest version of IOS 
  • Updating App by deleting and reinstalling 
  • Deleting App rebooting iphone and reinstalling App



Best answer by coletrickle26 9 July 2024, 19:57

View original

2 replies

Userlevel 2
Badge +1

If you have your font or text size increased on iPhone it may cause this issue. 

This is from Sonos in another thread - 

“We have identified an issue whereby some users will be unable to progress past the step of accepting the Terms & Conditions within the Sonos app.

Please ensure that you have not set your mobile device to enlarge the contents of the screen in any way - if you have, setting the zoom back to the standard setting may allow you to accept the T&Cs in the app.”

Thank you so much that has worked. I am up and running on my iPhone. I was so frustrated. This has sorted it.