The Sonos app on my Android tablet suddenly can't find my Sonos network

  • 27 October 2021
  • 4 replies

This evening I tried to use the Sonos app on my Android tablet, as I have done for months, But it couldn’t find the network. I can access the network from my PC, it’s there, it’s working, but following the most recent update, the app no longer recognises it. I’ve followed all the instructions - rebooting the router, disconnecting and reconnecting the Play1 speakers, holding the tablet really close to them, repeatedly trying again. Nothing. Then the app refused to let me log in to my account - my password and e-mail address were not recognised. Obviously the password and address are correct. I can log in from the PC - I’m logged in now - but not from the app on my tablet.

I erased the app from the tablet and installed a new version from the Play store. No go. So instead of some easy listening I’ve been scrambling around all evening struggling with technology. Sonos app says No.

Sorry. I know there’s no one can help me till tomorrow. Just wanted to ventilate.


Best answer by Airgetlam 28 October 2021, 22:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +18

Hi @JohinSweden 

Welcome to the Sonos Community!

When one controller can access a Sonos system and another cannot, it’s usually due to a difference in how the two controllers connect to the WiFi network. Do you have any WiFi Boosters or Extenders? If so, please try turning them off.

I also recommend a router reboot - please turn it off for at least 30 seconds.

If this issue persists, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

I hope this helps.

Edit: It’s not unknown for family members/guests to accidentally transfer a system over to their email - I’m not sure how they manage it accidentally, but it happens. You many need to follow the steps outlined in our Transfer your Sonos system to a new account help page (but use your existing account).

Thanks for the response. Much appreciated, but I have solved the problem.

It was down to a new virus protection programme (from Bytdefender) installed on the tablet. It didn’t block everything immediately, which was why I was confused. But I worked backwards through the  changes I’d made to the tablet recently, and when I removed the virus protection (and associated VPN), I could reconnect to Sonos without problems. I still don’t understand why the block happened last night and not immediately I installed Bytdefender, but I’m just grateful to have Sonos back.

Bytdefender and its VPN work perfectly on my PC without interfering with my access to Sonos, but I won’t be risking installing them on the tablet again.

It’s likely the VPN part. Basically, it’s designed to block all outside calls to the device it’s used on, and only allow a tunnel between that device and the other end. Which blocks the ability of seeing devices on your network, such as the Sonos. Often, they have built in exceptions for printers, if they recognize the printer driver properly, but I’ve never seen one that recognizes and pokes a hole open for your Sonos system to talk to your controller. 

Thanks Bruce. Useful.