Question

Spotify won't play on Sonos One any more

  • 19 September 2019
  • 16 replies
  • 12627 views

I have two Sonos Ones. Never had a problem until a week ago.

Now when I play Spotify on my Samsung S9 and choose the Grouped Sonos devices to play through, it says "Connecting..." but never connects.

If I then switch to the Sonos App it says "Last played in this room - Spotify" and under that it says Guest Account. This is despite me Removing the Spotify Account and adding it again.

I can then play music via the Sonos App over the Sonos Ones. But I can't connect from the Spotify app, which I've also reinstalled.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

16 replies

Userlevel 7
Hi BobbyF123

You must have a Spotify Premium account to effectively use it with Sonos. If you have a Premium Account then we need to look elsewhere.
I have a Spotify Premium account.
Userlevel 7
Hi BobbyF123

Try these steps....

  1. Log out of your Spotify account on all devices
  2. Unplug your Sonos
  3. Delete the Sonos App
  4. Reboot your router
  5. Power Cycle your device
  6. Re-install the Sonos app
  7. Plug in your Sonos 1x1 and let each come back
  8. Log into your Spotify account
  9. Test Spotify
Let us know how things sort out.
Power Cycle which device? My phone?
Userlevel 7
Power Cycle which device? My phone?

Whichever setup device you deleted the Sonos app from (i.e. iOS or Android).
I've been through that. It seemed to work at first but now we're back to the original symptoms.

It's strange that in the Sonos app it says Guest Account under "Last played in this room - Spotify".
Any more ideas?
I'm having the same issue. I was away from home for a couple of weeks starting mid-September, and I haven't been able to control playback of my Sonos One using Spotify Connect since returning at the end of September. I'm getting similar behavior where I attempt to connect to the device from Spotify, but it just says "Connecting..." and eventually times out.

This is happening both from my Android 10 phone as well as my Macbook running the Spotify app. I can connect to a plethora of Spotify Connect-enabled devices at my workplace on my laptop, so I am pretty sure there is an issue with my home Sonos One or a recent update that's been applied to it.

Same issue here. Just tried the simple and straightforward procedure suggested by @AjTrek1 😒 but to no avail. Any other suggestions?

I’ve been having the same problem for a while now. Is it because Sonos keep trying to upsell me to this thing to replace my bridge? I have 5 sonos speakers around the house and can’t connect to anything. It’s quite frustrating. 

The BRIDGE is old enough tech to have the potential for power supply issues, which can cause oddities in playback, but I wouldn’t normally think it would affect on stream more then others. On the other hand, different streams have different tolerances for disconnection, so it may be possible. You could test this by temporarily running the Ethernet cable to a speaker, and unplugging the BRIDGE completely. The speaker would then act in the same manner as the BRIDGE, without the potentially flaky power supply.

If that fixes the issue, you could just recycle the BRIDGE, you wouldn’t have to replace it with a BOOST, unless you wanted to. 

Badge

I too had this problem at the weekend with Spotify saying “Connecting...” and nothing happening. The fix was easy. Go into the Sonos application. Hit the cog for Settings, then Services. Click on Spotify and tap the “Reauthorize account” option. Problem solved for me, hopefully for you too.

I have been having this problem for the past few days as well.  My rooms show up in the Spotify app, but it says “Connecting...” until it silently fails to connect.  I have a 5.1 setup with playbase, ones, and sub, as well as 2 paired ones.  I can play Spotify just fine through the Sonos app, but cannot use Spotify connect to connect to either room from 2 different Android phones.  When I try to connect to my 5.1 setup, it stops playing from the TV, but never starts playing spotify.  I have tried this:

  • Rebooting the router
  • Reinstalling the Spotify App
  • Removing the Spotify source from the Sonos app and re-adding it
  • Reauthorizing the Spotify account in the Sonos app

I will try unplugging the speakers soon, but I fail to see how that could be the problem since everything works perfectly through the Sonos app.  The problem seems identical to the IOS bug where this would happen when the Spotify app is not allowed to use mobile data, but this is Android and I have not restricted the app in this way.

https://community.spotify.com/t5/Other-Partners-Web-Player-etc/Spotify-no-longer-connects-to-Sonos-speakers/td-p/4801465

 

Any other suggestions?

Same issue for me. It's been happening for a few days. Submitted a diagnostic, confirmation number 1526507123.

Badge

I have experienced a similar problem this weekend after returning from a business trip of a week. However, I have managed to restore the ability to connect to my Sonos devices (Sonos One pair in one room; Sonos Connect in another room) from my Spotify app.

My phone is a BlackBerry DTEK50 (don't laught, I take security serious) that runs Android 6. The phone has been overdue for an upgrade, which I have postponed for cost reasons. My restoration steps for the above issues have been:

Reinstall Sonos app (did not solve the issue). Allow Sonos app to be controlled by other apps on my phone.

Reinstall Spotify app. A few minutes after logging in, when I launched a song, Spotify app notified me that it has discovered my Sonos speakers and offered to connect. The connection succeeded. Voila!

My Sonos app is at the latest version and most of the management features are disabled due to the Android 6 situation.

It has been the final push. I have plunged and ordered a new phone that runs Android 8.1. Surprise surprise. It is a BlackBerry Key2. Happy days are here again (well, will be when the phones arrives).

 

 

I had same issue few days ago. Setting>>Services>>Spotify>>Remove Account and Add Spotify to Sonos again. Finally, this issue is solved for me, hopefully for you guys too.