Spotify - Unable to play (track) - the connection to Spotify was lost

  • 7 March 2021
  • 5 replies


I have the following setup:

  • Arc
  • One
  • 2 x One SL (paired in surround with the Arc)

All running S2 v12.2.2

My router is a Unifi UDM PRO running v1.8.6 firmware.  I have two Unifi AC-HD access points running firmware 4.3.2811361.

All five speakers have DHCP reservations from the router. I’m running a 24-bit subnet with no VLANs.

The Arc is wired (WM: 0), but all the other speakers are wireless (WM: 1).

When I use the Sonos app to play a Spotify track, everything is fine playing to the Arc or the One.  If I try to play to the SYMFONISK, it fails with the message “Spotify - Unable to play (track) - the connection to Spotify was lost” and skips to the next track which also fails with that message, and so on until the end of the playlist.

If I try from the Spotify app to connect to the SYMFONISK, it fails to connect without any error message.

I have rebooted the router, changed the DHCP reservations, power cycled the speakers and factory reset some of them but I still have the same issue.

This happens on multiple phones on the same wireless network.


I have submitted diagnostics reference 376721015.


Best answer by Corry P 9 March 2021, 17:04

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +18

Hi @roryd 

Welcome to the Sonos Community!

I highly recommend you re-enable WiFi on your Arc - this will allow your surrounds to operate the way they’re intended to, and probably help your Symfonisk speaker with it’s connection too.

Please also check the Best Answer in this other post - some UniFi settings may be getting in the way:



Hi Corry, thanks for the follow-up.

I have re-enabled WiFi on the Arc.

On the UDM Pro:

  • Guest Policy was already disabled
  • Block LAN to WLAN Multicast and Broadcast Data was already disabled
  • Auto-Optimize Network was enabled, but is now disabled

I disabled Auto-Optimize yesterday, but still today I am having the same issue with Spotify and the SYMFONISK speaker.

I have just submitted another diagnostics upload - 1469172201.

Userlevel 7
Badge +18

Hi @roryd 

Sonos speakers communicate with each other directly, even when using WiFi. To do this, they look for each other on the same WiFi channel as the network they’re logged onto. As your Access Points are using different channels (1 and 6), this is preventing the speakers from communicating in the way they’d like. We recommend that users keep all of their network access points on the same WiFi channel as each other.

However, I’m not convinced that’s the cause of your particular issue.

I only wanted you to reactivate the wireless card on your Arc, not disconnect the ethernet cable it had. Please reconnect the Arc to ethernet - this will make it transmit a WiFi network just for other Sonos devices, and each one that picks it up will rebroadcast it, creating a mesh network. This will mean that the Symfonisk speaker will connect to a closer speaker which will pass that connection on to the Arc, if needed. This may result in the Symfonisk getting a better connection.

You could also try swapping the Symfonisk for the Kitchen speaker - if the One performs better in that location, it may just be that the Symfonisk isn’t as good at picking up WiFi as a Sonos One.

If none of this helps, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.



Thanks Corry

I’ve reconnected the wired cable to the Arc, and I also changed the AP channel so that they’re both on 6 now.

All good so far, we can all play from Spotify to the SYMFONISK now.

Many thanks for your help.

Userlevel 7
Badge +18

You are very welcome - enjoy the tunes!