Answered

Spotify stops tracks and skips. No other music services affected

  • 18 January 2022
  • 1 reply
  • 236 views

Hello, 

 

I’ve seen the same question in this forum but all threads that I clicked on have been closed so I’m starting a new one because this is a new issue for me that just started occurring about a week ago. I have tried solutions suggested on the Sonos website and in the closed threads but nothing works.

I have been using my current set up for over 6 months. Nothing has changed in terms of new equipment in the house or any new potential interference. I have very strong wifi with a booster and today’s download speed is 531Mbps. I have restarted my router, removed Spotify from Sonos and re-added it. I can play music directly from Spotify to my Sonos speakers without an issue but every time I use the Sonos app to play from Spotify I experience issues from the get go. It won’t even play one song. Stops after a few seconds, skips to the next song, another few seconds of sound, then skips again and so on. 

The message I get from Sonos app is that my wifi is unstable - that is false. I check my speed and my wifi is not an issue whatsoever. It also told me I have an outdated Sonos One - I disconnected it from power but the same issue still persisted. 

All other music services like Soundcloud or SiriusXM work just fine.

My support diagnostics number is 1559476441

Thank you.

icon

Best answer by Sotiris C. 28 January 2022, 13:33

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 6
Badge +14

Hello @justaher, thank you for reaching out to our Community and I’m sorry for the late response.

A couple of things I would like to add to this thread.

  • You’ve mentioned having a booster and a download speed of 531Mbps. It is very important to know that the download speed is not the only indication that a network is working properly. Thank you for submitting diagnostics, as I had a look and they were incomplete. To my knowledge that occurs when there is a network connection issue. 
  • Doing a power-cycle, most commonly known as “remove plug from power socket → wait 10-15 seconds → plug back in” will refresh any network device such as your router and your Sonos products. Doing a power-cycle to both your router and Sonos products, will refresh the network connection between them resolving temporary issues.
  • When there is an error of this kind, showing network issues, what you can do is, if possible, temporarily connect your Sonos product directly to the router with an Ethernet cable. That will create a new private network called SonosNet, where all your Sonos products will connect and use to communicate with each other. This is very important as it will negate most issues with extenders and other networking devices. If the issue is resolved when wired, that means there’s an issue with your home network.

I recommend reaching out to Sonos Support while in your house, they can help you with some live troubleshooting. Feel free to reply here with any updates :)