Answered

Spotify Connect: Can't see the Sonos Beam

  • 7 February 2021
  • 4 replies
  • 3071 views

Hello,

I got a Sonos Beam recently and it’s very good but I’m trying to play music through Spotify Connect from my phone but it doesn’t even display the speaker.

I tried from my laptop and another phone (Android and iPhone) and no luck, no Sonos Beam displayed, despite being on the same wifi network (I forced every device to be on the 2.4 GhZ network).

I tried a lot of things (rebooting everything, disconnecting the app, etc.) but no success.

I can play Spotify from the Sonos app but I would like to just use Spotify Connect.

icon

Best answer by Gawel91 20 February 2021, 00:41

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 5
Badge +16

 Hi @Gawel91,

Welcome to the Sonos community. Thank you for reaching out to us and letting us know about your concern. Let me share some information with you.

Spotify Connect is a feature of Spotify that allows a user to listen to and stream music from the Spotify App. If you are experiencing issues with playing to Sonos from the Spotify app and are using Sonos app version 10.3 or earlier, please update your Sonos system by going to More > Settings > System Updates > Check for Updates.

You can control Sonos directly from the Spotify app by tapping on Devices Available devicesavailable.png on the Now Playing screen in the Spotify app.

  1. Open the Spotify app.
  2. Go to the Now Playing screen.
  3. At the bottom of the screen, tap Devices Available devicesavailable.png and select your Sonos speaker or group.

In some cases, wireless interference might be causing the issue. Wireless interference can occur when two or more wireless devices compete for the same WiFi space. If this overlap is causing performance issues, it can be quickly resolved by finding the source of the interference. You can also find instructions on how to reduce wireless interference in our short video. Let me suggest the next troubleshooting steps to see if it will work for you.

  • Sequential reboot to refresh your network and all your Sonos devices connection.
    • Unplug your network devices (modem, router, any wireless access points on the network) from the power and wait for 60 full seconds before you plug it back in.
    • Once the router is back online, unplug all your Sonos devices from the power.
    • Please wait 15 seconds before you plug back them back in.
    • Force close the Sonos app from your iOS or Android device.
    • When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.
    • Test playback from and observe Sonos performance.


If it's still doesn't work, you may need to contact our phone support team to look into this. Our phone support has the tools to check what's going on in your system and to remotely access your device to address the issue. Please let me know if you have any further questions or concerns, I'll be glad to assist you. 

Hi, I have the same problem, it used to work until a few weeks ago. Doesn’t work on both my phone or girl friends’ Spotify connect but works fine from Spotify app. All other Sonos speakers work fine in Spotify. Complete reset. Spotify & Sonos app removal/install hasn’t fixed it.

Userlevel 5
Badge +16

Hi @James376, thanks for reaching out to the Sonos community and for letting us know about your concern. Have you tried the steps recommended in this thread? Is your Spotify app up to date? If you're still facing the same, I recommend contacting our support team with your full network setup including the make and model of each device, and for more in-depth troubleshooting steps. Please let us know if you have any further questions or concerns, we'll be glad to assist you. 

Hi, some news!

After trying everything you listed (sequential reboot, wireless interference tips, etc.) I called the support and he helped me and after a while the problem was resolved :

In your router settings be sure to check the DNS settings, for me changing to the Google DNS (8.8.8.8 and 8.8.4.4) resolved this issue.

Have a nice day.