Answered

Sonos Radio Reauthorize

  • 11 December 2020
  • 39 replies
  • 1030 views

Userlevel 1
Badge

Hi,

 

My Sonos system comprises round 10 Play:1, several Play:3. All works brilliantly and I love it. Moved over to Sonos Radio and very pleased … apart from one thing.

Every 10-14 days alarms stop working first thing - I get the infernal chime instead of Radio 4 at 630am! When I check the app it says radio needs reauthorised. When I click to authorise it all works fine again and stays that way for another period of time before the whole saga starts again. This has now happened maybe 5 or 6 times.

Is there any way to make the authorisation permanent? I don’t have this authorise problem with Apple Music or Spotify. It is rather annoying as always appears on a 630am alarm then I need to fiddle around to get Radio 4 for wakeup!

If anyone can offer any assistance I would be very grateful. Thanks in advance!

Kind regards

Andrew

icon

Best answer by Ken_Griffiths 29 December 2020, 00:27

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

39 replies

Userlevel 2
Badge

and another me too.

Was happily playing 6 Music, went to change to Radio2 and failed to play, a tunein source played no problem, went into Music Source → Sonos Radio, instantly got need to re-auth message, clicked OK and all fine again.

 

Happens every couple of weeks

Userlevel 2
Badge

Just submitted 766185134 as it did it again this morning

Userlevel 2
Badge

I have been having the same problem.  I have to reauthorize every 1-2 weeks.  Not a major problem but it is a problem that should be addressed and fixed by Sonos.  Instead, they will just respond with the same infuriating answers (check your cable, isp speed, wifi channel etc) when they know damn well it is a common problem occurring with many accounts.  Sonos support … same as it ever was...

Userlevel 2
Badge

yup happened again for me, and agree checking your wifi channel is pointless, the only that that works is going into Sonos Radio and re-auth’ing

I have the same issue, exactly. I have done the things minus the reporting, but plainly it’s not a problem with my system. This is a problem with the app, please fix your stuff Sonos.

same. every couple of days? what happened to the SONOS moderator? no follow-up on the thread?

Badge

Same issue here, it’s been happening for months on end.  Only music service having this problem is Sonos Radio....so I read that as a not a hardware/wifi issue….it’s an app / music service issue. 

Super annoying, particularly with this many people having this problem for this long.  Hello bug fix?

this solved my problem:

  1. unplug all of your SONOS speakers.
  2. unplug your modem/router/access point(s)
  3. pause
  4. restart your modem (and then router, then access points if they’re separate)
  5. after your wifi network is fully up again, re-power all of your SONES speakers

i was having the same problem every few days. after reading all the entries on help forums contacted tech support. i have not had the problem since-- it’s been a couple weeks now.

You can, if you desire, do a more permanent version of that fix, by looking at your router’s manual, and assigning reserved IP addresses to all your network devices. Then you shouldn’t have to do that rebooting process again.

Note, that’s just a fix for the duplicate IP address issue, which happens on some routers more frequently. There are other, more common reasons as to why speakers disconnect from the router. Mostly covered in the wifi interference FAQ. 

Networking is fun!

Badge

I’ve had the same issue every day now for quite some time. Reauthorizing, playing, new day, reauthorizing …

This is a quite recent issue and has never been a problem until after the app was updated from 12.2.7 to 13. Network setup is the same as always, no changes at all. Sonos?

Asking Sonos is great, but if you expect an intelligent reply, you should submit a system diagnostic within 10 minutes of experiencing this problem, and post the number here, or call Sonos Support directlyto discuss it.

Badge

The same issues today … Diagnostic# is 1059917746. Will report to Sonos later today.

Badge

Quick update. Tried contacting Sonos in Norway, and after ½ hour unfortunately the answer was: we can’t help you… 

I have the same issue - Sonos Radio set as an alarm - regularly get chime instead and I have to reauthorise to fix it…...