Sonos Music Library won't update

  • 5 January 2022
  • 26 replies


This just started happening to me, my Sonos won’t update my music library. If i delete my music folder and re-add it will be have everything in there that should be, but if i add more music (mp3s, which i do almost daily) and have it update, none of the additions show up. 

my music’s on a macbook running big sur 11.6

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

26 replies

Userlevel 7

Check how many tracks are in your library. A Sonos music library has a 65,000 track limit. The limit can be reached by either track count or by memory usage. The memory limit can be reached prior to 65,000 tracks if there is a large amount of metadata. For example, classical music tracks tend to have a large amount of metadata and can use up the available memory before the 65,000 track limit is reached.

Also make sure your MP3 file sample rate is 48kHz or lower and the bitrate is 320kbps or lower.

You might also try rebooting your MacBook, deleting and re-installing the Sonos app, and rebooting your router.

hi @Bill_22 you mentioned you have your music on your MacBook but did also added the NAS tag to your post, so you may be interested in these steps to update an Apple Music library with Sonos - check in the Apple Music preferences the Music Media folder location which should be the same as the Sonos Music Library path settings


hi @Bill_22 you mentioned you have your music on your MacBook but did also added the NAS tag to your post, so you may be interested in these steps to update an Apple Music library with Sonos - check in the Apple Music preferences the Music Media folder location which should be the same as the Sonos Music Library path settings



the NAS tag is there by accident, the forum was suggesting tags and i thought i was deleting that one.

but like i said up until recently this was not a problem. and if i delete my music folder and re-add, all the songs it wouldn’t add before are there. most of my mp3s are 320/44.1


if you are using the Apple Music App on your MacBook you may need to manually update the xml file - check for a subfolder, called iTunes, and export the Apple Music library. Choose in Apple Music under the File menu the ‘Library’ option and ‘Export Library’. Store the library file ‘iTunes Music Library.xml’ in the subfolder. Remember that you will need to export the library each time you made changes to your Apple Music tracks or playlists since this file is not automatically updated.


i do use apple music but what does that have have to do with sonos checking my music folder and seeing if there are new mp3s in there. this should not be this complicated.

i do use apple music but what does that have have to do with sonos checking my music folder and seeing if there are new mp3s in there. this should not be this complicated.


The poster you are ranting at isn’t a Sonos employee (not that you should rant at them either), they are a user just like you.  They are trying to help you out of the goodness of their heart, so dial it back a bit or more than likely they will leave you hanging.

The iTunes Music Library.xml contains a bunch of information from your iTunes/Apple Music account, including any playlists you wish to import to Sonos.  This is why @el rubio is suggesting you include it in the path shared to Sonos.  They are just being thorough.


sorry if i seemed harsh. not trying to import apple music playlists. i just want sonos when i click “update music library” to actually update with the new mp3s i added to my music folder. 

but i still don’t understand why sonos makes it so complicated. you should be able to drag and drop!

thanks for the attempts at help everyone

Sonos doesn’t read the individual files in your directory. It reads the .xml file that has that list of files. Most applications create that for you, Apple requires a manual process to create that particular file. 


Edit: This is correct for playlists, but not correct for individual music files.


again this is a new problem. up until this week i could drop new album folders into my Music folder -- whether or not i added them to apple music (fka itunes) -- , click “update music library” in sonos and they would appear once it finished running the update. now the only way to get them to show up is to delete my music folder from my sonos library then re-add. which works but it just takes forever. i guess i was just hoping this was a new bug that other people were experiencing. i’ll call sonos support and see what they say.

Apologies, I misspoke. The Sonos uses the .xml files for playlists built in to Apple’s Music app, not the files themselves.

The Sonos system should be picking up the new files once you run the “update music library” function, albeit it may take some time, as that’s not an instant gratification process, sometimes, and depends on the speed of the device running the process. It’s not done on your controller device, but given to a speaker in your Sonos system to do, and if it happens to be an older/slower device, it might take slightly more time.  The slightly confusing aspect is that it’s being picked up if you delete the library, and re-initiate the process, which is what is leading me to believe there may be a timing issue. Normally, I’d have thought that the file was of an inappropriate format….but the fact that the file shows up after you delete, and reset up the path proves that thought incorrect.

I’d be really tempted to run a diagnostic from within Sonos several times….once before adding the new files to your system, then another after adding them to your system, then another after running the (failed) update music library process, and finally a fourth one after deleting and re-adding your library path. Provide all four resulting numbers when you call in to Sonos, and let them take a look to see if there’s something different between them beyond just the added files.


I started having similar issues.  When playing a playlist, I can have half of the songs in the list start for about 6 seconds, then claim the server connection is lost, and it moves on to another song from the same server just fine.  this is true for older playlists and ones created since upgrading from S1 to S2. Trying to back up to the previous song craps out again.  I also cannot update my index as about 30 seconds into the update process it will claim the connection dropped. This is true even with the S2 app running on the media server itself (which I tried on a lark, no wifi whatsoever AFAIK). So I have some music I’ve not been able to catalog since adding it to my library august/september timeframe.  The wifi is fine delivering some 200Mbit to all speakers.  I have a mix of play 3/5 and beam running at the moment.

I’ve tried checking windows update on the media server, checking firewall settings etc.  no change in behavior.

That sounds like some sort of wifi interference , causing a disruption between the speaker and the source when it’s attempting to access that particular song, then re-connecting when it asks for the next one. 

Since you claim the wifi is “fine”, my guess is that you’ve got some sort of IP address duplication. I’d certainly start by unplugging all Sonos devices from power, and while they’re unplugged, rebooting the router.  Once the router has recovered from the reboot, plug the Sonos devices back in to power. 

However, if that doesn’t work, I would certainly recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.

So based on some of the comments above, I unplugged everything, reset the router, and only plugged one device (beam) back in thinking that would substantially reduce the set of points of failure. Then tried to update my music index. Same issue, crapped out with a dropped connection in about 30 seconds.

So what did Sonos say when you submitted the diagnostics, and called in?

I went one step further and directly wired a single play 3 to the router and powered off all other Sonos components.  Which presumably keeps the router in the picture but eliminates the Wifi as a potential problem source. The problem persisted as far as updating the music index is concerned (have not tried playlists), so I am focusing on the server at the moment. As such I did not call Sonos but after I’ve exhausted sorting the server out, if the problem still persists will do so and report.


So what did Sonos say when you submitted the diagnostics, and called in?

i still need to call them

Userlevel 2
Badge +8

Been having the exact same problem. But starting yesterday, I can’t even add the Library BACK.

It worked okay for three years, and all of a sudden just stopped its daily update. Could remove and re-add, and it would pick up new stuff. Now it won’t even re-add.

I have been frustrated with Sonos since Day One. It’s like they say about democracy - it’s the worst system imaginable, except it’s better than everything else.

So I’ve had a couple of long calls with SONOS support.  Among other things we changed the Sonos channel from 11 to 6, and removing and attempting to re-add the music library to the system.  Now adding the music library does not work either so I am without a library. They have concluded that the netbook dedicated to hosting my library is the culprit and not the wifi or router. They suggested I move my library to another machine and call them back.  I do not have another server handy at the moment so am without the 20000 odd songs in the original library in addition to the 30 or so I’ve been unable to add since this problem emerged.

I will give them credit for the time they took, but sdaly am worse off for the trouble.

Since those calls  I’ve dug into the netbook server to see if there is some performance issue that would explain random connection drops, ruthlessly killed off processes and removed any fatware I could find, even turned the firewall off completely while trying to re-add my library.  It seems to go a bit longer before giving up the ghost but no joy there.

So I am a bit stalled at the moment, but thought i’d at least report on (lack of) progress to date.

Userlevel 2
Badge +8

Wow. OK that’s not good. I’m without my library too, which is annoying.

I’m also astounded at the fact that troubleshooting appears to be “Try this, now try that”. I’m not running a netbook or anything, just a hard drive. And the firmware on my router hasn’t changed. So within that loop the only thing that has changed is updates to Sonos. (If it was something on my PC, for example, then how does it explain that no other devices - Android, iOS - can add the library back?)

Given how basic the Music Library interface is, I reckon they just don’t pour resources into support non-streaming media.

Thanks for the update. I share your pain!

In fairness they are not in control of all the bits.  

My problem is I moved, and changed providers. So a different home router/configuration etc.  STBs are now wireless in this setup so there is more “stuff” on the wifi. (although even with them unplugged the problem persists), and a different router.

So at the moment I’m back to assuming a network problem, and ping testing is making me suspicious.  Just not sure how to fix it if it turns out to be true.


Userlevel 2
Badge +8

Provider shouldn’t make a difference, should it (although you say new hardware, too)? I mean, even if you disconnected from the Internet, the Library (and Connect) should still all operate internally.

(I can just hear the network engineers’ brains seizing up: Why would you ever be disconnected from the Internet?)

Yes, provider doesn’t really matter, but new gateway and home configuration is an additional variable, plus TV support is now over wifi instread of separate coax connected set top boxes.

I also had a lot more kit RJ-45 wired to my router in the previous configuration.  Now it is predominantly wifi connected.

Hi all,

This is a very long shot (almost tangential) for this discussion, but I’ll offer it in case it helps someone find a solution.

I was led here with a Google search for “iTunes Music Library.xml.” I’m wondering if Apple has changed something in the structure of the XML file, rendering that file incompatible with some equipment. I’m experiencing some problems described here but on a different device: 1) changes to my music library are not being picked up, and 2) I am (somewhat) without my library. 

Although I own Sonos equipment, I’m currently troubleshooting a Garmin smartwatch.

(Please understand, I’m not asking this group for help with my Garmin device. I’m simply offering these details since the symptoms are somewhat similar, and I’m wondering if the XML file might play a part.)

I use iTunes on Windows 10 to manage my music library. Garmin’s software no longer sees any of my music when I use the current iTunes Music Library.xml file. However, I can pull up an old XML file from several years ago, and the Garmin software still reads that with no problems.

For the original poster and others in this thread with problems, did your Sonos problem appear after a specific iTunes (Windows) or Music (Mac) update? My old-but-still-usable xml file was created with an older version of iTunes. I’m now running the current Windows version of iTunes,, which was released October 29, 2021. I’ve recreated the file multiple times, but my device does not recognize anything from the library (songs, playlists, artists, albums, etc).

As I said at the opening, this is a long shot. However, IF Sonos does use iTunes Music Library.xml to get a current snapshot of the user’s music library, AND IF the structure of this file has changed somehow with a new version of the software, that MIGHT be a contributing factor or at least something worth considering.

Good luck to everyone troubleshooting. I know it’s frustrating.



So I have some good news to report. Doing some online reading I discovered the http interface to my individual SONOS components and was able to understand a bit about the topology and where my problem was.

Basically http://x.x.x.x:1400/support/review  where x.x.x.x is the IPv4 address of the component of interest and once there you can click on network matrix.  Typcially a class ‘A’ (10.x.x.x) IPv4 private address.

One thing I had not realized was that the spanning tree that the SONOS network converges upon can see an individual component using both the wifi and the wireline interface.  In my configuration it meant the hardwired play 3 in the office was also the root bridge of the spanning tree and was using wifi as well. From the network matrix reports (going through the components one by one and simply looking at the color codiing) I was able to discover it had a high ANI (ambient noise interference) value to some of my components. So the longer it took to catalog my library, the higher the liklihood of an unrecoverable communication error. Simply repositioning the play 3 in the office to get a lower value cleared things up.  Mentally envisioning line of sight to the other components helped, so try to avoid large metal objects like fridges and bathtubs. So while I had great bandwidth to some of my components as measured using tools on my iPad, the actual connectivity was crap from the POV of good enough for music.

So all is good in my world. Hope this helps!

In a similar boat here. The controller will no longer recognize my external drive and i am without my library. Very frustrating.