Sonos Move and AirPlay 2 volume issues for first track played

Userlevel 1
Badge +1

Hi I have a Sonos Move, and iPhone 11 pro (all software up to date). When I use siri to play music on the Move from my local iPhone music collection, the first song played is abnormally loud, and so if I don’t adjust the volume, the 2nd song played is very quiet. If after using Siri I adjust the volume slightly it jumps down the normal level.

I have used ivolume to normalise volume across my collection and the tracks are fine on other airplay 1 speakers (but of course they can’t be played with siri), so I think this is an issue specifically related to Sonos and airplay 2.

I have Alexa enabled on the Move and notice similarly that despite asking Alexa to set volume 3 - quite a low level, it’s always really loud when it starts next time.

Has anyone else experience this and any suggestions on how to fix it?


Best answer by Jack Hennety 5 June 2020, 19:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Userlevel 1
Badge +1

Update - I’ve been in touch with Sonos support and exploring the issue further. A few things I’ve found out:


  1. The issue only occurs if soundcheck is on.
  2. The issue occurs across different iphones with different users, so it’s not specific to my phone.
  3. The issue doesn’t occur when playing from a Mac or ipad OS.
  4. The issue is a bit more general - it is not related to siri. Any music manually played from a local ios sound library to Sonos Move has this issue, whereby the volume level falls significantly for the next song. If you then adjust the volume up it’s fixed, but then if you for example skip the song a little the volume jumps up (so it seems the issue is still in the background but adjusting the volume up fixes it if you don’t do anything else). 
  5. I don’t know if it’s related to my use of ivolume but all that does is set the ‘volume level’ field in the song to a fixed value, so it shouldn’t cause this issue.


This definitely seems to be a bug and I’m surprised no-one else has posted about it - am I really the only one with this issue?

That sounds more like an Apple issue with AirPlay 2 on the iPhone than it does with the Sonos….unless I’m misunderstanding your repro steps. 

Userlevel 2
Badge +1

am I really the only one with this issue?

No, you’re not.  I’ve been seeing this for a good while on my system too.  Not exactly the same symptoms but very similar.

I have various Sonos speakers around the house.  Very frequently when I start AirPlay-ing Apple Music content to any of them (from iPhone 11 Pro Max, also fully up-to-date), where I’ve set the volume to be reasonably loud, the next song in the list to play will start at a much-reduced volume.  If I skip back to the start of that second song, it will start playing at the ‘correct’ volume ie. the volume that it was on for the first song.  It will remain ok for that song, then the next song will start much quieter again, necessitating a skip back to its start.  A total pain.  

Having seen your thread, I’ve tried switching Sound Check off and so far, that seems to be doing the trick.  But I’ll need longer to confirm for sure.  I agree that it looks like an Apple Music bug, as it doesn’t happen if I play the same music directly through the Sonos app.  I will log it with Apple.  If you and others do likewise maybe they’ll look at it.


Userlevel 1
Badge +1

Hi Jack, thank you for posting. Good to hear I’m not going mad, but annoying to see that’s it’s definitely a bug. I have an open support query with Sonos so will go back to them to see if they can push for a fix.  

I’ve emailed Apple but if only a few people are noticing and reporting it I don’t have much faith in them resolving it. Airplay 2 seems to have been buggy from the start but are we certain it’s an Apple and not Sonos issue? I’m picking up a Libratone zipp mini 2 so I’ll report back if the issue exists with that speaker too. 

In the meantime you’re right - the more people that report the issue the better. Turning off sound check is not a fix as you then have to adjust between each song for volume anyway if you’re shuffling music.  

I’m so glad you posted this because I thought I was going crazy. I’m an Apple Music user and have been having this issue since getting my Sonos One SLs about 4 months ago. It’s so annoying to have to adjust the volume after that first song and again when the volume shoots back up. I haven’t tried with any other service like Spotify but I’m assuming it would be easy to figure out if it’s an Apple or Sonos problem. Any updates from Sonos? 

Userlevel 1
Badge +1

Hey, it is really annoying isn’t it. I don’t think Sonos know much about the bug but I’ve  reported it to Apple and encourage everyone to do the same. I’m guessing Apple only do something if enough people report it. 

Does anyone have a non Sonos airplay 2 product they can check the issue on to see if it’s specific to Sonos or all airplay 2 devices? I didn’t get a Zipp 2 in the end so can’t test with a different manufacturer. 

While I’m at it - airplay 2 is dreadful. How can Apple introduce a new streaming standard and have such obvious and fundamental bugs?!

I have the same issue. When streaming through Airplay the volume jumps completely unpredictably. Sometimes between tracks but also in the middle of the song which means it is most definitely not a Soundcheck issue. It’s wild and it’s driving me absolutely nuts. I do think that it started when I got my iPhone 11 though so it might be an Apple issue. Before that I had the 6S and no problems.

Userlevel 2

I have the same issue with Apple music and  airplay 2.

I have 3 Sonos one’s and Ipad mini.


tested with a Denon home 150 speaker and the same issue.


bug in iOS i  think.

Userlevel 2

I dida test with iOS 14 beta 2 and 3 problem not solved.

Userlevel 1

I’ve been facing this issue ever since March, when I first got my Sonos system. I currently have:

  • 1 Beam
  • 5 One SLs, two of which are paired in stereo
  • 1 Port, which I use with a Bluetooth receiver via line in
  • Apple TV 4K

I also briefly owned a Move, before realizing that Bluetooth was not an input into the Sonos System, but rather its own standalone mode that completely disconnected the Move from Wi-Fi. I pretty quickly returned it after that.

My issues with AirPlay are exactly what’s been described by OP. Here’s what’s going on in a bit more detail:

iOS - AirPlay 2 to any Sonos device or Apple TV 4K

With Sound Check enabled, the first song fails to engage Sound Check, and plays at its original volume. When playback continues into the next song, Sound Check engages and sets the volume, usually lower (you can check how much the adjustment is by right clicking on a song, Get Info, File tab on Apple Music on the desktop). If at any point playback is interrupted in any way, whether by seeking within the track, pausing/playing, skipping to a different track, or even a dropout due to network latency, Sound Check becomes disengaged and the original volume returns. On some very loud tracks, this can be quite shocking and upsetting! I’ve reported this to Apple but I haven’t heard back.

iOS - Bluetooth receiver to line in on the Port

Sound Check works the first time, and every time. No issues, no complaints.

macOS - AirPlay 1 on system audio settings

In macOS, it’s possible to stream the entire system’s audio over AirPlay 1, which has a 2 second delay and can only go to one destination. To do this, click on the volume icon in the menu bar and select a speaker. With this method, Apple Music plays with Sound Check correctly (but playing and pausing can be quite unreliable). 

macOS - AirPlay 2 from Apple Music to any Sonos device or Apple TV 4K

Sound Check does not work at all. Songs on the same album will be the same as each other (depending on the production quality), but songs on different albums will be different. I’ve reported this to Apple but I haven’t heard back.

Apple Music directly on Sonos

Sound Check does not work. See above. I’ve provided feedback to Apple on this. They said Sound Check on Sonos is unsupported, and they have no plans to implement it, which is very frustrating.