Answered

Sonos Cannot Find the Computer it is running on

  • 2 September 2022
  • 2 replies
  • 178 views

I have used a Mac from late 2013 as a music server since that date.  All was working well until it updated to Catalina and simultaneously I updated to S2.   Since then, Sonos cannot find the music library saying that it cannot find the computer.  S2 is literally running on the computer itself.  I worked with customer service and it was determined that this was likely due to the known problem with Catalina’s security update that messed up File Sharing on Mac computers.  Indeed, this problem was present.

So, I moved all of the music files over to my PC via an external drive.  I copied the files onto a SSD drive on my PC.  I then tried to link the music library on the PC, and I am getting the same message--S2 cannot find the computer, now the PC, it is running on and therefore cannot index the files.  

On both computers, I can see and play the files using other applications.  

I ran a diagnostic on the PC right after this occurred.  The diagnostic number is 1588168447.

I have once again asked for tech support.  They adjusted privacy and file sharing settings on the new computer but to no avail.

Help?

icon

Best answer by John B 5 September 2022, 12:52

View original

2 replies

Your Sonos devices are having trouble resolving the names “MACBOOKPRO-757D” and “Chris-Imac” into IP addresses on your network.

 

 

Given that the music library now resides on a PC and not a Mac, I wonder why it is looking for these names still?  Has the old folder path been removed from the Sonos Music Library?  

On a Mac, special characters in computer names can mess up SMB sharing.  Also, I wonder if the two names given are the Computer Name and NetBios name from the Mac.  These need to be identical on a Mac for Sonos to find the Music Library.  Don’t know if any of this is relevant to the PC but may explain why it wasn’t working on the Mac.

Userlevel 7
Badge +18

Hi @cokii 

Welcome to the Sonos Community!

Your Sonos devices are having trouble resolving the names “MACBOOKPRO-757D” and “Chris-Imac” into IP addresses on your network.

There is also a possible IP address conflict on your network.

First, please try rebooting your router by switching it off for at least 30 seconds.

If that doesn’t help, I recommend you get back in touch with our technical support team, who have tools at their disposal that will allow them to help you directly - I advise a phone call from the outset.

 

Reply