Sonos can no longer find the path to my iTunes library

  • 15 May 2021
  • 5 replies
  • 891 views

I updated my Mac to Big Sur and Sonos S1 Controller no longer recognises the path to my iTunes library, gives message “//iMac-Main-4596/Music in no longer available.”  I checked the firewall settings (Sonos is permitted), unchecked “Share Files” in privacy settings, nothing produces the result.  The name of Mac is correct, as stated in File Sharing settings, the only difference is that it is iMac Main 4596.local, however when I tried this in my mobile app (on iPhone) it relied that the computer does not allow access.  I could not find library setting in the S1 Controller.  As a result no changes made to my iTunes library are synchronised to my Sonos Library.  Any suggestions?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7

Under System Preferences > Sharing, do you have the “Music” folder added in the Shared Folders window? What items are checked in the window on the left side?

I have iTunes and iTunes Music.  But the whole File Sharing tab is unchecked.

I added Music folder to Shared Folders, tried updating the Sonos library with File Sharing both checked and unchecked, made no difference, I’me getting the same message.

Userlevel 7

Try the steps mentioned in this thread:

https://en.community.sonos.com/music-services-and-sources-228994/why-can-t-i-add-my-music-library-to-sonos-on-my-macbook-air-running-latest-macos-big-sur-6851511

Reinstalled the controller, deleted the iTunes from Music Library sources, added it anew, works now.  Thanks for your help.