Sonos 14.18.1 and My Cloud EX2 Ultra

  • 3 November 2022
  • 1 reply

Userlevel 1
Badge +3

Hello Everyone,

Since the version 14.18.1, I have a problem with my local library on My Cloud EX2 Ultra.

All my speakers and my Nas have a IP static addresses.

The library works fine during 3 days / 5 hours / 1 day and the library disappears from the Sonos app> I must update manually. Sometimes my library disappears from the Sonos app.

The Nas My Cloud works with the protocol SMB3, I have checked with the other protocols SMB1 and 2 and the problem appears also. I have also checked with an other Nas My Cloud but the problem persists. My network is always the same, no modifications, no new material.

Yesterday, I have phone with the support, solution given : uninstall and reinstall the library. That was fine during the day, the evening and today, library not present in the Sonos app.

Honestly, I am a little lost about this issue.

Thank you for your help or your ideas.

Kind regards.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @Fragments Of 

Thanks for your post!

Intermittent problems are just the worst.

From what I can tell looking at your most recent diagnostics, the issue seems most likely to be that all of your speakers are reporting repeated lost connections to the network. If the unit that happens to perform the indexing is disconnected at the time it chooses to do so, that may well produce the problem you describe. Why these disconnects are happening is unclear to me without more information, but you should be able to bypass the issue by permanently connecting a (ideally) centrally-located Sonos device to the network with an ethernet cable - this will make all your non-portable speakers connect to it instead of to your WiFi. Please keep it at least 1m away from any other WiFi devices, especially the router or mesh nodes. With this done, please wait for a minute or so then check in Settings » System » About my system that all your non-portable speakers report WM:0 and are present in the app. Once this is so, please change Settings » Network » SonosNet Channel to 1. If any rooms go missing soon after this step, you may need to switch back to channel 6  to recover them and then try again. While on the subject of channels, I recommend you move your WiFi to channel 6, as channel 7 overlaps both channel 6 and 11. 1, 6 and 11 are the only 2.4GHz channels that do not overlap.

Another possible source of the issue is that you might have two routers on your network - it certainly looks like you might have both a router and a mesh system, and if the mesh system hasn’t been told to not perform as a router, it will be doing so. To prevent this, you’ll need to put the mesh system into Bridge/AP mode. You’ll find more info on my troubleshooting article:

Even if the issue does turn out to be due to having two routers, I still recommend wiring a Sonos product to ethernet to increase your system’s stability and reliability.

I hope this helps.