Service Stack issue when trying to map NAS to SONOS1

  • 6 December 2023
  • 9 replies


I’ve got a My Cloud Home and a Sonos1. I know the My Cloud service has been switched off so I’m having to try and map the NAS drive with my music manually.


On a Win11 laptop using the SONOS1 app.

I can select the NAS drive however when I try to connect I get the ‘serverstack’ error. I’ve set the  

IRPStackSize REG to 24 (DEC) as per the faq but that hasnt helped.


What else do I need to do? I’ve seen various messages re SMB - how do I check that on a My Cloud Home NAS drive? 

Any assistance is appreciated.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
Badge +22

Try here

Thanks. I’ve tried that with no joy. The SMB 1 protocol is key but I am not sure how to check that on my NAS. The Web interface doesn’t show this option. How do I check this on a My Cloud Home?? 

If I remember correctly, there were some MyCloud devices that didn’t offer you that option. You may want to reach out to Western Digital’s customer service directly. I’m afraid I’ve given up on a Western Digital NAS in favor of a Synology, so I no longer have access to that web interface. 

Userlevel 7
Badge +22

After dealing with WD support I switched to a different NAS option too. Good luck with them.

I also have decided that WD My Cloud Home is not worth the hassle. I tried to help a couple friends with their WD and decided that it would be best to use the drive in a “window toss” event. My conclusion was that WD envisions the system will be used along with a phone/pad to remotely store photos on their cloud server while on vacation, then access through an online phone/pad.

It’s odd…I hate to pile on to WD, as I do love their drives…but there has been so much drama over their NAS support. I did put WD drives in my Synology.

Userlevel 7
Badge +22

Different Divisions inside WD?

The WD hard drive from inside my now trashed WD Live is still working fine in another system and WD drives are my first choice (by a lot) when buying either bare or USB connected drives.

I have 8 USB WDs on my ‘backup shelf’ here and at least two bare drives in each computer.

I’d think it likely. And I think one line of their NAS were designed by bean counters, to optimize sales, as those appear to be the devices that lack the ability to allow the user to choose which version of SMB is in use. And the naming seems to be so odd that it’s hard to tell which version is which. I’m sure it was all in the thrust for ‘simplicity’, and for most uses is fine. Just not for Sonos. But their prevarication on the plug in that they wrote to use for Sonos, then retracted…more evidence of poor product management, IMHO. Of course, I’d have been unlikely to approve that particular product from the beginning. 

And apologies to the OP for dragging this way off topic.