Samba share works on 1 speaker, not on the other

  • 16 March 2023
  • 3 replies

Userlevel 1

I have an S1 Sonos system with 1 Play:3 and 1 Play:5. I have a Music Library Setup to my samba share at //servername/media that has been working just fine until I replaced my wifi router last weekend. I’ve re-added the share and I can navigate around within the share just fine from the Sonos S1 app. When I try to play music from it to my Play:5 I get an access denied error. I can play music from it just fine to my Play:3, and if I’m playing music from it to my Play:3 I can then group in my Play:5 and it plays on both of them. If I then remove the Play:3 from the group, it stops playing on both. Please help, thanks! -Ross


Best answer by rpmohn 17 March 2023, 18:42

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

My thought is to reboot the PLAY:5. Refrain from Factory Reset without further consult.

While I agree, I’d be awfully tempted to reboot every device connected to your new wifi router, to ensure that they all get refreshed IP addresses, as well as DNS data….and anything else that may come along with a refreshed connection. 

Userlevel 1

I was finally able to resolve this problem by adding the line unix extensions = no to my /etc/samba/smb.conf file and then running sudo systemctl restart smdb.service.

I found the answer setting by log level = 5 and then inspecting the log file for the IP address of that speaker, /var/log/samba/log.nnn.nnn.nnn.nnn. There was an error with the text (SMBtrans2) NT_STATUS_INVALID_LEVEL and a search on that text brought me to the answer. No idea why it worked before, but happy with the fix.