Qobuz skips through tracks

  • 18 November 2022
  • 11 replies


I’ve been on Sonos for about 5-6 years, mostly using Spotify. Six months ago I started Qobuz and recently every song I play is fine for up to 30 seconds then it skips to the next track. On every track I play.

I’ve rebooted the router, unplugged my Sonos 5, and temporarily removed my Sonos Move. Nothing has worked. Can someone please help me?


Best answer by Sotiris C. 24 November 2022, 12:21

View original

11 replies

This is usually an indicator of your speakers inability to stay connected to your network on a regular basis.

When you rebooted the router, did you have the Sonos Five or PLAY:5 (there is no Sonos 5) unplugged? If not, I’d recommend trying that, in order to clean up potential IP address conflicts. You could also, if you desired, go in to your router’s software and assign reserved IP addresses for your Sonos.

However, if you have already done that process, it might be something else, like wifi interference from either inside or outside your network. Worth reading through that FAQ, and possibly changing the broadcast channel you’re currently using. I had a new neighbor set up a network using the same channel as I was, and it caused issues for me….once I tracked that down, and changed the channel I was using, things cleared up. 

Finally, if neither of those potential solutions work for your system, i would recommend that you submit a system diagnostic within 10 minutes of experiencing this dropout issue, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network. 


Thank you for the step by step instructions. I did as you suggested, same trouble, so I called Sonos. They did a diagnostic and told me Sonos should be on a 2.4 network, not a 5. I can’t find a way to change this on my mesh network settings so now I am stuck. 

Really disappointed. I thought everyone uses the newer technology these days and Sonos doesn’t support it?

First I’ve heard of any “requirement” to be on a particular frequency for your network. Makes me wonder if you got a CS rep that’s reading from a script, without actually understanding what the issue is. 

I don’t run a mesh network myself, so I’m not that handy with suggestions, but perhaps if you post which particular network devices you’re using, there’s someone in the community that can help you. 

Also, you can run a “wired” network by either cabling one of your current speakers to your router with an ethernet cable, or a Sonos BOOST, which would remove that at as potential issue. Even if that was a temporary test just to see what happens. 

I do know of particular instances in which there’s a Sonos sound bar in the mix in which 5Ghz isn’t recommended, as they only have one antenna for 5Ghz, which is consumed by the surround speakers, but that shouldn’t be impacting a spare Five or PLAY:5 (which do you actually have?) that’s its own “room” in the Sonos software.


The mesh network is an Eero Pro5, the router is in my garage with an extender on the other side of the wall opposite the router. My Play5 Gen2 is in the same room as the extender, about 10 feet away from it with a direct line of sight. I don’t have any Ethernet cables in my home.

 The service rep sounded like he was reading off a  script the entire time. I kept pressing him that 5ghz has been out a while, it has millions of installed locations but he just kept telling me that only  2.4ghz is approved. He suggested I contact Verizon and have them split the signal from the router to my Sonos off as 2.4ghz. Really? 

I’m not a network admin and I bought into the Sonos ecosystem 5 years ago to avoid exactly this kind of thing. I brought a Bluesound Powernode upstairs to the far side of the house on the same network. It’s rock solid. Sonos was too (on 5 ghz) until about a month ago and it’s broken now. 

Sonos often doesnt like some mesh networks, as the way they tend to function is by splitting up each ‘puck’ into different subnets. You’ll frequently see suggestions in these forums about running the Sonos system in ‘wired’ mode, with one or more units directly wired to the base router. 

It’s hard, I would think, to hire CS people who are network experts, and am somewhat unsurprised that you ran in to one who was reading from a script. You may want to try calling in again, and see if you might get someone more conversant, but at the very least, I’d recommend trying wired mode to see if that may resolve the issue. 

Conversely, while it’s not their main function, the forum moderators here seem to be fairly knowledgeable. You might post a diagnostic number here and they would be able to read it, and likely give you better advice based on the hard data, something I certainly don’t have access to. 


I will give the support line another try… or two because I really like the Sonos UI. It’s hard to believe that Sonos engineers have not yet figured out how to work with mesh networks and 5 GHz protocols yet. 

These more advanced tools are what I would think their target audience has adopted.

Userlevel 4
Badge +8

Hello @Wdrazek, welcome to the Sonos Community!

Did you experience any issues with your Sonos while using Spotify? That specific “30 seconds" gave me some thoughts.

After doing a little research, this issue is most likely related to your Qobuz Account.

Qobuz users say that a quick log out → log in on their accounts resolved this. So probably a quick re-authorization is all that needed.

I would recommend contacting Qobuz directly though as, most likely, they are aware of this issue and could assist you further.

I hope this helps.


Thank you for the suggestions. I did try removing Qobuz and reauthorizing it. That did not work. Nor did uninstalling it from my phone and reinstalling.

The Qobuz app works on my phone, on Air Play and on BluOS, but not on Sonos. In the end, Qobuz referred me back to Sonos since it works everywhere but Sonos.

I am getting the same issue! Did you ever find a solution?


Yes. Sonos support reached out yesterday. They said to remove my network from Sonos and reinstall it. They also said not to use the 5Ghz network but the app doesn’t show which is which. After reinstalling the network it worked. When I first used Qobuz on Sonos it worked then too. 

Since I can’t choose the 5Ghz or 2.4GHz network on the Sonos app I don’t know whether the connection will remain viable. 

This episode has caused me to consider whether Sonos still works for me. I’ve replaced my Move and the Play 5 will probably be next.


I always set up my router with different names for each frequency, so I know which one I’m connecting to. Your router may or may not allow that, but it’s been helpful to me. I know others have just turned off the 5Ghz frequency. 

Although most recently, I have used a wired network, so my speakers (except for my Roam) connect to SonosNet, and not my WiFi’s signal.