Products failing to update, tried multiple things

  • 6 November 2022
  • 6 replies
  • 156 views

Badge +1

So here is my setup:

  • Living Room - Arc (hardwired), Symfonisk frames, and sub

  • Master Bedroom - Beam, Symfonisk frames

  • Dining Room - Beam

About two weeks ago I was having this weird issue where I couldn't play any music to just Master Bedroom, it kept giving me some weird error (I cannot remember now what it was). Now, it would work if I played on the Dining Room and then added Master Bedroom to the group, but not the other way around.

Now for the past few days when I'm trying to use Sonos, it says there are updates available, but when I try to update it I get "Error 30" or “Error 1001”.

I have a firewall running pfSense for my router. Currently what I have done is unplugged every piece of Sonos I have, rebooted my router multiple times, and have started with the Arc in the Living Room, both wired and unwired, and keep getting update errors. Can anyone help please?

6 replies

What happens if you temporarily turn off pfSense?

@NurseWizzle,

I’m not familiar with pfSense, but a user with a similar issue posted this on Reddit;

So maybe that will help you solve the issue, perhaps🤔?

Badge +1

What happens if you temporarily turn off pfSense?

I'm not sure but that's my Internet so… it won't be able to update?

Userlevel 7
Badge +22

The default setup of pfSense should not be an issue. If you have added firewall rules or pfBlocker they could be an issue.

You might power down all but one Sonos and try updating, do the rest one at a time.

The static/reserved IP settings in the router’s DHCP settings has saved me much frustration over the years. It isn’t just a pfSense issue but it is present there and bites at update and power cycle events.

30 https://support.sonos.com/s/article/4905?language=en_US

1001 https://support.sonos.com/s/article/4887?language=en_US

What happens if you temporarily turn off pfSense?

I'm not sure but that's my Internet so… it won't be able to update?

This confuses me. Previously, you stated ‘I have a firewall running pfSense for my router.’. All I’m suggesting is that you temporarily turn off the firewall, which is likely blocking the speaker’s connection to Sonos’ update server. 

Userlevel 7
Badge +22

Turning off the firewall in pfSense isn’t possible (or I can’t find it) but you can disable the rules you have added which is functionally the same thing.

The pfSense software runs on a variety of hardware, from dedicated firewall devices to desktop computers. It is an integrated BSD based system that offers a variety of services: edge firewall, router, and VPN functionality but serving as a router is the primary for most home users.

 

Overview:  https://www.netgate.com/pfsense-plus-software

Firewall Rules: https://docs.netgate.com/pfsense/en/latest/firewall/rule-list-intro.html

Documentation:  https://docs.netgate.com/pfsense/en/latest/

Reply