Plex integration: "Unable to play '[track]' - the connection to Plex was lost"

  • 1 December 2021
  • 40 replies
  • 2971 views

Userlevel 1
Badge

Sonos version: 11.2.13

Plex version: 1.25.0.5282 (same issue encountered with 1.24.x.x)

Plex running in Docker container on an HP MicroServer serving music stored on same server. Plex app works fine and can browse/stream music from internal LAN and from outside LAN. Sonos app can browse music on Plex fine.

Until recently, I’ve been able to stream Plex music to SONOS without issues. It stopped working a couple of days ago. A new Plex update became available today and I’ve tried that with no success.

 

Problem description:

I believe the following are related issues as they started at the same time.

Variant 1:

Using the SONOS appFind and select track from Plex. When Sonos attempts to play track it reports error:

Unable to play track '<track name>' - the connection to Plex was lost.

Variant 2:

Using the Plex web app, the cast locates SONOS boxes but when trying to connect reports:

Playback Error
An error occurred loading the media being played on "<sonos device>".

 

Expected behaviour:

SONOS plays music as expected. Plex app is able to connect to and stream music to SONOS device.

 

Troubleshooting so far:

  • No errors detected in Plex logs
  • Tried rebooting all network devices
  • Tried reauthorising Plex with Sonos
  • Tried removing/re-adding Plex in Sonos (including removing app approval in Plex)

As far as I can tell, my network is fine. I was able to play tracks the other day and can’t play anything now. Plex app works as it should so don’t think the problem is there. I’ve run out of ideas to try now, and have been unable to get through to the support chat

Does SONOS or anyone else have any idea where I can go from here?

Thanks in advance.


40 replies

Userlevel 7
Badge +20

Hi @pwt 

Thanks for that. Yes, we tested a speaker on a mobile hotspot connecting via LTE to the Plex server. Our Plex settings match yours, and Strict TLS doesn’t appear to make any difference.

Are you running the native Plex server, or on a Docker Container?

It’s in a container, running with ‘--net=host’, so it should behave from a networking perspective as if it’s running directly on the host.

Userlevel 7
Badge +18

Hi @pwt

It’s in a container, running with ‘--net=host’, so it should behave from a networking perspective as if it’s running directly on the host.

And we’re doing the same. We still can’t reproduce the issue - though it seems related to SSL. 

Hopefully, more information will come to light soon. Until then, being unable to reproduce, we’re unable to continue.

Userlevel 7
Badge +20

Hi @pwt

It’s in a container, running with ‘--net=host’, so it should behave from a networking perspective as if it’s running directly on the host.

And we’re doing the same. We still can’t reproduce the issue - though it seems related to SSL. 

Hopefully, more information will come to light soon. Until then, being unable to reproduce, we’re unable to continue.

Thanks. Just to check: you’re testing using an S1 Sonos system?

If so, this is really odd. It used to work perfectly, but stopped doing so several months ago, despite no changes in networks or other relevant configuration settings -- other than normal software updates to Sonos and Plex.

I did wonder if it might be as simple as a certificate expiry, but if you’re not able to reproduce the issue, it’s not that.

Userlevel 7
Badge +18

Thanks. Just to check: you’re testing using an S1 Sonos system?

If so, this is really odd. It used to work perfectly, but stopped doing so several months ago, despite no changes in networks or other relevant configuration settings -- other than normal software updates to Sonos and Plex.

I did wonder if it might be as simple as a certificate expiry, but if you’re not able to reproduce the issue, it’s not that.

Yes - S1.

My tier 2 colleague is now trying with the official Plex container as he wasn’t utilising it. 

Userlevel 7
Badge +18

My tier 2 colleague is now trying with the official Plex container as he wasn’t utilising it. 

Which made no difference. Still unable to reproduce.

@pwt would you mind creating a new test container with a new instance of Plex in it and test if that fails too?

We are unable to reproduce this issue. This is good for other users, but it makes it harder for us to help you all here.

@Ken_Griffiths - I’m told you have a different issue than the others - no NAT Loopback will prevent Plex from working.

Thank-you for looking into this issue @Corry P. that’s much appreciated👍. I will continue to press Plume to have the option to enable ‘Nat Loopback’ on their router. Plume have been canvassed about the issue previously and by others too, so I’ll see how that goes.

There are other ways to play the same music on Sonos, so it’s not a bother, other than perhaps the time spent trying to eventually get to the crux of the matter.

Userlevel 7
Badge +20

My tier 2 colleague is now trying with the official Plex container as he wasn’t utilising it. 

Which made no difference. Still unable to reproduce.

@pwt would you mind creating a new test container with a new instance of Plex in it and test if that fails too?

I can do that, but not for some time, because I need to test using my remote Sonos S1 system, which is installed at a different property.

If I get time, I might flip my local S1 system onto a different network to the Plex server, and use that for testing.

I do appreciate you & your colleagues taking time to look into this.

Userlevel 1
Badge

Apologies for the delay responding.

I’ve just tested this issue again and I can no longer reproduce this either, despite the problem persisting for months previously with various versions. Seems like something has changed in the Plex/Sonos integration or something that was cached has expired (I’d restarted everything multiple times previously to no avail).

For reference, I’ve been running Plex in a Docker container on an Ubuntu server. External port access and NAT hairpinning are all fine.

I forgot to note what version of Plex I was running before, but it started working there. I’ve just updated to 1.25.6.5577 (which only has ‘preferred’ and ‘required’ as secure connection options) and it works in Plex internally (e.g. 192.168.x.x), in Plex externally (e.g. 80.x.x.x), via app.plex.tv and from Sonos. i.e. all seems to work everywhere so looks to have been resolved. For me, at least…

Userlevel 7
Badge +18

Hi @timmyc 

I’m glad to hear that the issue, for you at least, now seems to be resolved - thanks for sharing those details, and for updating us all here.

Is anyone still able to reproduce this issue after reboots and updates?

Userlevel 7
Badge +20

Hi @timmyc 

I’m glad to hear that the issue, for you at least, now seems to be resolved - thanks for sharing those details, and for updating us all here.

Is anyone still able to reproduce this issue after reboots and updates?

Yes, still not working for me. Latest versions of everything.

Userlevel 7
Badge +18

Hi @pwt  

Yes, still not working for me. Latest versions of everything.

That’s unfortunate. If you happen to find anything out about what’s going on, please update us here. Thanks.

We are unable to reproduce this issue. This is good for other users, but it makes it harder for us to help you all here.

@Ken_Griffiths - I’m told you have a different issue than the others - no NAT Loopback will prevent Plex from working.

@pwt & @timmyc - Could you please let me know your current Plex server network settings.

Just to briefly mention, I did liaise with Plume support over the (on-going) NAT loopback issue and now with the latest Plex server update too and assistance from Plume, I have Plex now working on all platforms including Sonos and can at last enjoy my Plex lifetime pass.

Great for when travelling/camping around the UK to be able to access my home music/media library and play to the Roam (or Move). So all’s well that ends well.👍

Userlevel 7
Badge +18

Hi @Ken_Griffiths 

Fantastic! Glad to hear it! Thanks for updating the thread.

Chiming in to say I have the same issue as described above. It’s intermittent: from the Sonos app (S2 everything) I can browse music from Plex and start an album. Sometimes the whole album will show the error, one after another. Sometimes just a few songs, then randomly it will start playing one. Sometimes no issue.

I’m not on Plume, but Unifi.

Chiming in to say I have the same issue as described above. It’s intermittent: from the Sonos app (S2 everything) I can browse music from Plex and start an album. Sometimes the whole album will show the error, one after another. Sometimes just a few songs, then randomly it will start playing one. Sometimes no issue.

I’m not on Plume, but Unifi.

Maybe try the Sonos system setup in SonosNet mode by wiring one Sonos device to your primary unifi Hub/Router and see if that may perhaps resolve the intermittent issue for you.

Reply