Answered

Play 5 (gen 1) and Spotify problem

  • 23 May 2021
  • 3 replies
  • 222 views

I have searched in other topics, but i have not found any answer or fix for this problem.
Suddenly during a song it can stop for a couple of seconds and then continue again. This is very frustrating. 

What i have tried so far is. Changing router, channels on the router. Connecting through wifi and also with ethernet. All kinds of resets. I have tried using Spotify connect and also the Sonos app. I’ve tried from different devices too to connect.

I also have a Play 1. No problem whatsoever with that one.

I have tried other streaming services (Youtube music & Apple music) and with them there’s no issue at all.

I’ve had this problem for more than a year.

I just submit a diagnosic: 1540223134

icon

Best answer by Corry P 24 May 2021, 11:09

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7
Badge +18

Hi @kubisztal 

Welcome to the Sonos Community!

I’m not sure why you only experience this issue with Spotify, as it looks suspiciously like the Play:5’s radio link is getting interfered with - please check our Reducing Wireless Interference page and move any possible sources of interference to at least 1m away from the Play:5 (and the router). It looks like it’s a non-WiFi device that uses the same frequency as WiFi. This could be a smart electricity meter, a baby monitor, a microwave oven or something else.

I recommend you also change your WiFi channel to 1 - it seems the best option given what your neighbours are using.

Connecting either the Play:1 or the Play:5 to the router with ethernet could help the Play:5 too, but reducing the noise is the most important step.

I hope this helps.

Thank you for the reply. I have changed to Wifi channel 1. It worked well for a while, then the same problem came back. Still only with Spotify.
I need to do some more testing during the weekend. What i could think of that is interfering is my philips hue bridge. 
It still doesnt explain why the problem only happens with Spotify. I have tried other sources too. Radio stations, amazon music, tidal, apple music, youtube music. Local library, everything is perfect except for Spotify.

Userlevel 7
Badge +18

Hi @kubisztal 

Understood. Thanks for trying that.

Could you please try disabling the Crossfade and Shuffle features while playing to the Play:5 to see if it improves matters?

Please also try grouping the Play:5 to the Play:1 and playing Spotify (as in, please select the Play:1 and tap it’s group button) and monitor the Play:5.