Answered

New Windows 11 refuses Sonos access to Music Library

  • 27 November 2022
  • 33 replies
  • 3272 views

Userlevel 1
Badge

I have a new HP Windows 11 PC that replaced my old Windows 10 PC.  The new PC “refuses” Sonos 1 Controller access to my Music Library.  The old PC, when put back on network, still allows access.  I have spent many hours with Sonos tech support, also with HP support, Norton antivirus support and Microsoft support, all without success.  We have uninstalled and reinstalled the Sonos app on my PC more than once, have changed Norton traffic rules, blocked firewalls, uninstalled Norton, made sure Sonos has all permissions, checked SMB, used the InPlace file to essentially reinstall Windows 11, etc.  Sonos has assured me that the Sonos 1 Controller is compatible with Windows 11, but all other tech support point to Sonos being the problem.  Am I the only the one experiencing this problem?  If not, what solution have others found other than the unsuccessful manipulations mentioned above.

icon

Best answer by Kirk D 17 December 2022, 00:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

Userlevel 1
Badge

The initial error messages I was getting were on the order of “The computer [computer name] cannot be found.”  Later it was that the computer refused access to the Music Folder.  My suggestion for anyone running across similar problems is, after you do basic trouble shooting (like enabling SMB-1 and setting network to private, etc.), to insist on Level 3 Sonos support.  Level 1 support was time consuming, redundant and worthless.  Level 2 quickly punted to Level 3.

BTW, after resolving the above issue, the next day I could not access the Music Folder again.  But this time simply rebooting my router and Sonos components (unplugging and plugging in my Connect and Play 5s) quickly resolved the issue.  I don’t know if rebooting both was necessary or whether rebooting one or the other might have worked.   In either case this measure had not worked before the more technical Level 3 support made the changes outlined in my previous message.

Userlevel 2
Badge +3

For some folks (I use a Buffalo NAS) and as I recall, Sonos access and indexing is finicky about the Secure Messaging Block protocol.

 

Because it is working I have not converted the protocol. If I do, I will likely need to change the switch in the NAS config.

 

You can search for my earlier post of all details of this configuration with a Buffalo NAS on this forum. (I found in my NAS, a switch for “Switch between” that threw a wrench in everything. I recall I set it to SMB1 (the older less secure encryption)). On update, Windows 11 isn’t allow opening the drive as a mapped drive or with its ip address. Fortunately for me, it DOES allow me to access and play things just fine from my Sonos controller (mobile and windows varieties).

 

Hope this may be of some help to some folks.

 

Hi, I had issues connecting my NAS (Synology) to Sonos S2 and couldn’t find the answers so am posting it out if it helps others. 

Under settings > music library > input the NAS address under the LAN settings, which is one digit away, in my case 192.168.1.2 instead of 192.168.1.1

Another tip is not respecting the syntax suggested by Sonos, but input in the following style: //192.168.1.2/music

with Login and Password if applicable

Restart and voila!

I have Also a new HP pc, and excactly the same problem; i’m not so techinical, but I can help myself on pc.
Also Norton 360, restall it over and over again, nothing helps.

Please help me

 

Charel B

 

I had a similar problem with the Android App (Sonos S1) attempting to locate my music library on a freshly-constructed Windows 11 machine. My new PC had the same settings as the old PC, the only change was that I named the new PC the same as the old one and change the name on the old PC to something different to avoid any network issues. Also, the music library on both PCs was exactly the same - same drive, same folder naming, same tracks.

I tried many of the ideas suggested in this discussion but my solution was somewhat unique, First, I thought it might be a weak wifi signal since the Play 5 speaker was located at the other end of the house where wifi coverage is known to be weak (the microwave easily interferes with the wifi signal at this end of the house). I thought I’d bring the speaker closer to the PC, instead I grouped the speaker with another Play 5 that was already in the study. That went well. I then thought I’d better update the system before I try another connect. Went into the Android app and when to “System Updates” and selected “Check for Updates”. The app asked me to provide my login details which I entered. My system was up to date and no downloads occurred. Went back to “Music Library Setup” and behold the music library I had been attempting to connect to was there. Note: while the music library details was the same for both PCs, I had entered new details several times in an attempt to get things working.

I’m not certain what the solution was exactly. When attempting to connect to the library the message observed was “XXXXX did not respond”, where XXXX is my computer name. So, was the issue simply a weak wifi signal and pairing the far-away speaker with one closer to the router fixed this problem? Or was there some interrelationship between the Android app not being logged into Sonos HQ and the fact the  speaker couldn’t connect? I’m hesitant to attempt eliminating one of these options, after nearly six hours of frustration I don’t want to end up with a lost music library! Another note: I didn’t need to “Update Music Index Now” before I played a test song. Such an update usually takes several minutes, but I could play music instantly. Yes, I had previously used my Android app with my old Windows 10 music library.

Anyway, hope this contributes to helping people who are fighting to get their Android app to connect to a Windows 11 music library. Consider weak wifi signals and ensure the app is logged in.

 

 

On a W10 system I worked with the ports required by SONOS were not enabled to pass through the firewall.

Not quite for the feint of heart: First make sure that there are entries for SONOS, then open these settings and make sure that that the required SONOS ports are allowed. Scroll farther down on this page for the list of ports.

On a W10 system I worked with the ports required by SONOS were not enabled to pass through the firewall.

Not quite for the feint of heart: First make sure that there are entries for SONOS, then open these settings and make sure that that the required SONOS ports are allowed. Scroll farther down on this page for the list of ports.

I use Eset for my network security. Personally, I’ve never had to set up any ports for my Sonos system. Contained within the firewall rules are two Sonos rules (in and out) for the desktop application. Both rules are very generous in which ports they allow. I’m no expert in networking, but I though the firewall was only relevant to controlling the interface between the local network and the external network (the internet)?

Badge +1

This is probably the actions of a dangerous, computer illiterate nut, but…

Private network > Defender Firewall ON > incoming connections > clear “Blocks all incoming connections including those in the list of allowed apps.”  I can now “see” my music library and windows (11) controller works.  But was having same issue.