New app

  • 29 November 2020
  • 3 replies

I am struggling to connect my sonos to my WD cloud mirrror which is on a home network to link my music library again. . It used to work before the app was changed, I get an error code 900. Tried them help line but it only works from 09:00 - 17:00 no good to me as I work the same hours. Can anyone assist. I have also tried downloading the app onto a computer and through this have been able to point direclty to the required file but still no joy. Any help would be greatefully recieved.

Thanks John21


Best answer by Airgetlam 30 November 2020, 00:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Frequently, trouble connecting Sonos to an NAS is due to SMB v1 (Samba version 1] being turned off in the software that runs the NAS. In fact, more than one background update to that software on my WD device has turned off SMB v1, requiring me to go back into the WD front end and re-enable it. Have you checked this?

Also, have you checked the error codes FAQ?

Or maybe it is time to submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it, or post the diagnostic number here for a Community Moderator to pick up.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, there are more options available beyond just the diagnostic analysis. 

Hi Bruce,


Thank you for your reply. I tried the fix and it has worked. Simple and a 2 minute fix. I wish i could of had this information from the chat i had with Sonos on Sunday night. It took and hour to get nowhere.


very grateful

Kind regards


You’re welcome. Now, if we could either convince Sonos to update S2 with a newer version of SMB, or have the NAS updates stop turning it off in the background updates...