Music service skipping after a period of time doesn't recover, unless paused

  • 27 November 2020
  • 1 reply

Diagnostic number: 882209052
Hi i have been having this issue ever since i purchased this system... i haven't tried it on all music services (which i will do) but the testing i have been doing is on streaming iHeart Radio. It seems that after a period of time the speaker or group of speakers starts to loose the stream and skips, it gets worse once it starts and doesnt recover. if i stop and start the group of speakers it works for a while ~1hr, then starts skipping again. I have replaced the router, switches and access points and this still happens. 
One test i've done is to split the group of speakers into two with each group having a hardwired set of speakers, this has proved that it's not the wifi as these speakers suffer the same issue. 
I have also started the second group of speakers after the first lot start exhibiting the issue and they work fine with the same service as the first set continue skipping. i will continue testing but would appreciate any suggestions on fixing this.  

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @Sammyt, thank you for reaching out to us, and welcome to the Sonos community. We appreciate you for letting us know about your concern as well as the steps that you have performed, and also for submitting the diagnostic report. Let m help you with this.

Upon checking the report, you have 2 speakers wired to your router but the WiFi is disabled on both speakers. If the WiFi is disabled, only the wired speaker is in SonosNet and the rest of your speakers are connecting to your WiFi network or Mesh network. Also, an audio dropout was detected in your due to sync error, an audio playback failure in your Sonos system. This could be the reason why you're having an audio issue. 

Let me suggest the following steps to see if this would work for you.

  1. Enable WiFi on both of your wired speakers
    • In the Sonos app, tap the Settings > System > Tap the name of the room (wired speaker) > Under Products tap the model of speaker > Select Enable WiFi
    • Test audio playback
  2. Ungroup and  your speakers
    • Test audio playback if you will encounter audio skipping on each speaker
  3. Interference may be also one of the causes of a weak wireless connection.  
    • Move away from the devices from your Sonos speakers or turn them off. 
    • Check Sonos if there's an improvement with the performance.
    • Relocate the affected speaker(s) to determine if it is a wireless range issue.
  4. If you have access to your router settings, below are the settings that need to be verified. You can contact your Interner Service Provider or router manufacturer for assistance.
    • The auto channel must be set to Off
    • Choose the best non-overlapping channel (1,6,11)
    • Set channel bandwidth to 20MHz
    • Both 2.4GHz and 5GHz should be enabled
    • UPnP should be enabled
    • 802.11 bands should be set to b/g/n
    • Airtime Fairness should be disabled (if applicable)
  5. You can also run through the Music service audio stops or skips troubleshooting guide 

If you're still experiencing audio stop or skip, I recommend contacting our Sonos Customer Care support with your full network setup including the make and model of each device, to check hardware compatibility and to perform more in-depth troubleshooting steps to provide you the best option. If you need help with any other information, please be sure to let us know. The Sonos Community is always here to help.