Music Library not updating correctly

  • 28 November 2020
  • 5 replies

I have added an additional album to my music collection and after many updates this is still not showing in my system.

I have less than 3000 tracks in the library so space should not be an issue

I have checked the metadata and this looks to be correct

I am using both Windows 10 and Android 10 for the update process

The music library is stored on a NAS drive and only this album is missing

Are there any error logs generated by the system that I can view that may throw any light on the problem?



Best answer by ClausN 29 November 2020, 14:30

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

There is not much of an error log that we can access. You can go to http://[IP address of a player]:1400/support/review. Here you will see a list of players. Click on a player, then open Zone Player Info for the player. About 2/3 of the way down the list is the field IdxTrk that is normally blank after the index is complete. If there is a text string given here, this is the last track being processed when the indexing fails. This will give you a hint about the problem track. You may need to chase through all of the players looking for a non blank entry because you don’t know which player has been executing the library index.

Indexing is done by a player. you can actually shut down the controllers while the indexer is running. You have very little control over the order of processing. Basically, the indexer asks the NAS to return a list of files and the NAS controls the list order. I don’t assume that the NAS will return tracks in the same order on successive runs of the indexer.

Do you happen to have 2 albums in your library with identical titles? I once had a similar issue, and dupe titles, with same artist, turned out to cause one of them missing in Sonos.


Thanks for the updates.  At this stage at least I only have one device, so I have looked at the track index and this is blank meaning I think that the indexing process has been successful or at least completed.  Will this also mean that the index process has not found an error?

I am now not convinced it is indexing at all, tried update library and then refresh of Player Info and the Index field is still blank.

I have checked through and as far as I can see there ate no duplicates.

Is the file in a format supported by Sonos?:

If you look in “Music library” → “Folders”, do you see the album? If so, re-check the metadata.



Thanks for the suggestions.

I started by creating a new NAS share and only moving a couple of albums and the one that was not working still did not.

So tried re-ripping and used WMA at the lowest bit rate and success.  So yes the issue was the file format, it was WMA Pro.

All restored and working fine.