Internet radio station recently switched to HTTPS and is not accessible through Sonos anymore

  • 17 February 2021
  • 5 replies



One internet radio station I’m listening to recently switched to HTTPS and is not accessible through Sonos app anymore.


Old URL which now redirects to the new stream




I’ve tried to add both URL manually but it won’t connect and there’s no error message at all.


It works if trying through a browser, ITunes, VLC, Audacious or if I’m using Logitech Media Server to stream it to my Sonos Port.


Any idea how to make it work again?





Best answer by controlav 18 February 2021, 15:14

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +23

That site uses a root certificate from Lets Encrypt, and that provider is not supported by Sonos players (which is not surprising, their rep is not great). The list of trusted root certs can be found here:

You should contact the stream provider and ask them to use a “better” root certificate.

Userlevel 5
Badge +9

Do you know that your Port is running that latest software version? I’ve no idea how quickly that list of Certificate Authorities changes at Sonos, but the article that Controlav points to does say that they may be updated over time, so it’s possible that Let’s Encrypt may already have been added and you don’t yet have the software update?

@controlav Indeed that explains the issue here. Still having an error message stating an issue with the certificate authority would have been great instead of silently failing. Maybe something to consider for Sonos :slight_smile:

As that radio is not commercial I somehow doubt they’ll purchase a certificate when they can get a free one by Let’s Encrypt, an authority which is accepted by most operating systems and browsers.

I guess Sonos users only make a tiny percentage of listeners anyway so I’ll continue streaming it through other means while hoping Let’s Encrypt is accepted one day.


@Antifon Yes everything is up to date. Sonos port and Sonos app but still no luck.

Reading a bit further in that developer link I do see DST Root CA X3 as an accepted root authority.

As Let’s Encrypt is the intermediate authority here probably the SSL server should be setup to send the whole chain in order to make it work as it is mentioned in that article.


Userlevel 5
Badge +9

Interesting that their cert uses an ISRG root cert. I would suggest waiting a couple of weeks to see what happens on 3rd March! The current cert expires then.

It may be that PBB has changed hosting recently and that cert was thrown in for free? That happened when I moved a website to a new hosting company recently. You may find that when it expires they have to pay for a cert that chains up Ok to a known root?