Gapless playback issues after 15.2 update


Userlevel 3
Badge

Is anyone else having issues with Gapless playback after updating to 15.2?

 

Scenario:

I have been using a loopable track on Apple Music via the built in Sonos player to play sleep sounds every night for years. This created a seamless sound with Gapless playback. 

Problem:

After the update to 15.2, there is a distinct gap between the end of the track and the beginning of the repeat making the feature unusable for sleep sounds.

 

Fix Needed

Restore previous function to allow Gapless playback on looped tracks.

and/or 

Allow reverting to a previous firmware

(Ideally allowing to revert by atleast two firmware revisions to allow people to experiment and see if a new update has fixed a previously experienced bug)


103 replies

Hi

I am having issue described with gapless music via Apple Music.  I listen to a lot of dj mixes and can clearly hear there is a gap when it goes from one track to another.  Happens when I have spatial settings on and listening to Dolby atmos mix.  I am running version 16.2 with latest Sonos app via Era 300.  If I disable spatial music via settings everything is ok.

Quick update, made a mistake.  It is also happening if I have spatial disabled.  Any gapless dj mix I play has a small noticeable gap.  I have tried with wifi plus Ethernet connection and same issue

Userlevel 1

So… Now I’m having the opposite problem. The next song is playing too quickly, and the beat is off with DJ mixes. It’s like Sonos engineers decided to “build in” a slight crossfade to resolve the issue. Uhm… 

Reply