Connection lost to TuneIn

  • 30 January 2021
  • 4 replies
  • 166 views

Sir,

Sometimes my SONOS system seems to lose connection to Tunein randomly. Is there anything to learn from the diagnostic information?

I uploaded the diagnostic information within minutes after the loss of connection. 

The conformation number is: 1417785516.

My provider downloadspeed is 50Mb/s. No abnormalities in my network. As far as I can see.

Regards, Rob


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

In a more direct answer to your question, Sonos only creates its own network when at least one device is connected to your router with an Ethernet cable. This network is called SonosNet, and is essentially a WiFi network of its own, but using your router’s DHCP table, operating on the channel you designate, from the choices of 1, 6, or 11. The intent is that you select one of those for your own wifi signal, and choose one of the others for SonosNet. Those specific frequencies have no overlap, so should not interfere with each other, but would certainly both be susceptible to other ‘outside’ interference. 

Sonos has a pretty good FAQ about wifi interference already, although I’d add more stress on the possibility of outside of the local network sources, but that’s due more to personal experience and angst. ;)

And of course, being network devices, both wired and wifi Sonos devices are subject to the potential of duplicate IP addresses, which is actually an issue with the router, but is frequently exposed when Sonos does a software update, which causes the Sonos devices to soft reboot, and request new IPs. 

Userlevel 5
Badge +14

Hi @Rob Everse.

Thank you for reaching back to Sonos Community.

This article will help you why we need to choose Wifi channel 1-6-11.

And to avoid wifi interference with Sonos speakers click here.

 If you need help with any other information, please be sure to let us know.

Mark,

Thanks for the swift replay. My modem/router, provided via ISP, is a DOCSIS 3.0 with auto channel optimization. Deselected that and put in the mentioned settings. First impression is positive.

Leaves me with one question. I assumed the SONOS system builds its own WiFi network independent of the routers WiFi network. How do those 2 networks overlap? Where is the interference?

Regards, Rob

Userlevel 5
Badge +14

Hi @Rob Everse.

Welcome, thank you for reaching out to Sonos Community, We appreciate your time and effort in posting your concern here in our community.

Can you please check if the settings of your router are configured properly? You can contact your ISP or the manufacturer of the router for assistance.

a. Auto channel must be set to Off

b. Choose best non-overlapping channel (1,6,11)

c. Set channel bandwidth to 20MHz

d. Both 2.4GHz and 5GHz should be enabled

e. 802.11 band should be set to b/g/n

f. Airtime Fairness should be disabled

Let us know if it works. If you need help with any other information, please be sure to let us know.