Cloudflare Warp Blocking Sonos Controller for Mac Access to Service

I have started doing more with my MacBook Pro. As a result I tried to use Sonos Controller for Mac to control my Sonos Play:5 Gen 2.

I have the following 

  • MacBook Pro running macOS Monterey 12.4
  • Sonos Contorller for Mac 14.10 (build 68330100)
  • Play:5 Gen 2

I have Cloudflare Warp

  • Version 2022.5.342.0 (20220616.9)
  • Excluding the following IP Ranges
    • excluded to enable Logitech Flow a virutal KVM switch.
    • workaround proposed by Cloudflare
    • workaround proposed by Cloudflare

The controller could not find the Play:5. I found a workaround proposed by Cloudflare back in June 2021 until a fix was implemented in Warp. I would have thought it was fixed after a year but no joy. When I added the 2 IP ranges Sonos Control could find the Play:5 without turnign off Warp. However the controller cannot see the contents of the services and start playing music with Warp on. In order to play for example an Apple playlist. I have to turn off Warp. Then find and start the playlist and turn back on Warp. At that point it sees the music getting played and works just fine even if I leave Apple Music. Using Sonos Controller on my iPhone which runs CloudFlare Warp works fine. I don’t even have to do the excludes.

I did troubleshooting which is how I found the 239 and 255 ranges to exclude which enable me to see the Play:5 without turning off  Warp. I also saw I had the Play:5 on a different SSID although it is on the same router. Change the Play:5 to the same SSID as my MacBook made no difference. I am sure I am not setting something.

Any help would be greatly appreciated.   

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies



I have the same issue on Windows with the Sonos S1 Controller and Cloudflare WARP. It was working for more than a year.

I can control the music in the playlist, but the controller cannot see the contents of ALL my services (Deezer, Amazon Music, SiriusXM, etc...) to add new music.

Strangely, I see the content of Sonos Radio (without the thumbnail images). 

What do I need to open in the VPN?



Just to confirm. The configuration I posted was working. When did it stop working?



I sent feedback to Cloudflare with diagnostic logs.

I don't know if they have worked specifically on this problem, but I no longer have the issue with WARP version 2022.8.869.1 and the Sonos S1 controller for PC version 11.5.