Channel doesn't exist

  • 23 November 2019
  • 23 replies

Userlevel 1

Has anyone else experienced the error message “The channel does not exist (anymore)”. I am getting it on all channels on SiriusXM. I have reset my router, rebooted my phone and the message still shows. My SiriusXM works through their app but now through my Sonos. Thanks in advance for any help.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

23 replies


I have the exact same problem with Sirius XM, all morning, Apple Music works perfectly but not Sirius XM, the Sirius app works well by itself.

Same issue here

Userlevel 1

It is now working. Why? I have no idea but it is so try yours again. 


Ditto. Same thing. I tried a bunch. “This channel doesn’t exist anymore”. At first, I was getting it for the channel group (News/Public Radio).

Radio by Tune-in works fine.

Deedlebug57: I’m glad it’s working for you. But, not for me. I restarted the application on my Mac. But it still doesn’t work.

Working again too.  Strange.

I have the same issue.  It’s telling me channel doesn’t exist when accessing SiriusXm.  Did a reboot of everything and still having the problem.

same issue

I’m having the same issue.  If I use the phone app, I get the error “ channel doesn’t exist when accessing SiriusXm” but if I tell Alexa to play the station, it works.  Not sure what has changed

Same issue with xm, works fine in app.  This happened after i upgraded my app this morning.

have removed station from apps and added back. have rebooted systems. still have “the channel does not exist (anymore)” message. 

it’s working now after 2 hours of not working 

Userlevel 2

Yep! Getting "channel does not exist"... At least not with Sirius XM



Getting same thing today.  I’m wondering if this keeps happening every once in a while when Sirius does an update to their station list.  (My car radio pauses and says ‘refreshing stations’ every so often).  Maybe an internal ID or something is being used by Sonos behind the scenes and until Sonos refreshes this on their servers, we’re dead in the water..


Me TOO.  Siris and Amazon does not exist……….Hmmmmm

Any answers to the problem?

All Sonos does is point to a SiriusXM location/server. Any changes at that location are handled by SiriusXM, and not Sonos. You may be better off calling them, rather than posting here. 

If its a siriusXM problem, then why is also Amazon at the same time…….Dont think so.

Userlevel 1

My service came back at 8:30 am. I heard from Sonos this morning and let the technician know that I had an issue and it had resolved. I also let him know that there were other customers experiencing the same issue. I ran a diagnostic and sent the info to Sonos. I hope you all get your service back soon.


Yup, back now here too.


Issues resolved for me as well by itself.


NOT back here. Getting the error message “unable to play (name of station)”.  All other DSP’s play fine, and we can play it directly via the app, but not through Sonos.  


What’s up, Sonos?


Same problem here, which started yesterday.

I’m having the same problem today with both SiriusXM and Amazon music

I just got it to work by updating my password in the Sonos app (even though it’s the same password).