cant reauthorize or add apple music to sonos

I simply can’t get Apple Music connected to my Sonos system. I’ve uninstalled and reinstalled Sonos as others have suggested. I deleted Apple Music from my account to try and re-add the service. I get the same problem every time. I select “ already have account”, it opens the Apple Music landing page to connect, I select connect, and it just hangs forever. It did this when I tried to reauthorize, and now it’s doing the same to reconnect it. 

super frustrating. This is my primary listening mode with Sonos. Other suggestions to fix?


Best answer by Ken_Griffiths 8 August 2021, 00:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

15 replies

Do you perhaps have another mobile controller you can try? I’m not an Apple subscriber, but if I try to add the Apple Music service to my Sonos S2 App, it takes me to the in-built native App and opens this page on my iPad (see screenshot).

I’m fairly sure it would then go onto work if I were to subscribe… obviously I can’t continue to the next step, but it looks like everything is working okay.

Userlevel 1

I had the same issue. I could not authorize apple music on my samsung android note 10 even though it was working previously. I was about to cancel apple music when I realized i had an old ipad in my closet. I figured I'd give it a try. I fired it up, updated the OS, then downloaded the sonos s2 app on the ipad. Viola! I was able to add apple music service back in. It now shows up in my android devices! Try borrowing or using someones ipad if you dont have one. You will hopefully only need it once.

Userlevel 5
Badge +8

It appears that there’s a known problem that the Sonos Android app can no longer add or re-authorize Apple Music. It has been reported many times to Sonos going back over a month, and they are still playing dumb about it and wasting everyone’s time rebooting the speakers and checking WiFi.

Userlevel 1

Yeah-rebooting the speakers and checking the wifi is bullcrap. It’s just Sonos’ way of trying to point the finger at the consumer instead of fixing their garbage app! If anyone is having issues with adding apple music, try my method listed earlier today. It works!

Userlevel 5
Badge +8

My iPad is too old to run the Sonos app, so that’s not an option.

I finally bit the bullet and updated from S1 to S2 in hopes that it would help with this problem. After wading through that hot mess of an update, it didn’t help. It has the exact same problem with Apple Music as S1.

Userlevel 1

Sorry to hear that. Did you update the OS on your iPad? I had to that as I couldn’t download the S2 app until I had the latest OS.

Userlevel 5
Badge +8

My old iPad is already on the last iOS update that Apple allowed for it.


Apple Music is equally broken in the S2 Android app, and the update process S1 -> S2 is a hot mess. S2 adds a bunch of new incompatibilities (like no more support for Win7), and you can’t revert to S1.


Ah bought Beam gen 2 couple days ago mainly planning to listen to music from Apple music. As I'm an android user I encountered the same bug in Sonos app and now I just enjoy the silence. Actually might be better this way. I became too hung up on material things, hifi-sound and technology. Thank you Sonos for opening my eyes and mind. I don't need any of this, the silence is all for me now on and hopefully for other users too. If you have an android I mean.

Same problem blank page after selecting member for login on the S2 app. Android 11 on Google pixel 3a xl. Uninstall everything and all for nothing. Must read this post first. Apple music seems broken. First Sonos speaker not really impress!! Please fix this...

Same issue here. Tried from three different android devices with three different apple music accounts. Latest android, apps, S2, etc. Just shows a white empty screen after I click “I’m already a member”, and that’s it. What a shame :(

Might be useful to check this thread:


Not the answer you’re looking for, but information that is useful, nonetheless. 

Userlevel 5
Badge +8

Notice that this problem has been reported and confirmed by many users for over 2 months, and Sonos not only hasn’t fixed it, but they haven’t even acknowledged it. They’re still making customers go through pointless diagnostic procedures as if they had no idea there’s a problem.

We all understand that not every problem can be fixed promptly, especially when it’s between two companies who apparently aren’t talking. But pretending that the problem doesn’t exist is unfair to customers and not helpful to anyone.

I’m confused by your statement that “they haven’t even acknowledged it”. If you click on the link above that I provided, the “answer” to that thread is an acknowledgement from Sonos that they are aware, and are working on the problem. 

Userlevel 5
Badge +8

Thanks, glad to see you got that answer from Sonos when the rest of us didn’t.

The time has come to contact the CEO of Sonos, Patrick Spence.  Mr. Spence is listed on the support page for Sonos to be contacted with issues.  Just like everyone else who contacted Sonos support, I was told to add Apple Music via an IOS device.  Support is fully aware of the problem, however will not admit how long the issue has been known.


Contact Sonos CEO Patrick Spence at on behalf of all Android users to fix adding or reauthorizing Apple Music on an Android device.