Cant play DLNA / Network folder Library - Error 701

  • 21 November 2020
  • 1 reply

Hi All

First post here, and I thought I would try here before o contact Sonos Support directly.

I've been using a Sonos System for 6 years without issue, but today I've tried to play some music from my NAS via DLNA, and I'm getting error 701, can't add to queue. Research tells me it's a comms issue, so I've rebooted my Router and one speaker to try and resolve, but to no avail.

DLNA Media Server is enabled my NAS, media server and upnp is enabled on the Sonos App. I can search my music via the App, and I know its correctly searching, as I change the content directory on my DLNA Media Server on my NAS to a single folder, and I can find and search that folder in the App, so I know its working between my App and my NAS.

My system details are below.

Does anyone has any suggestions?

I've even tried adding a Media Library via a Folder Share, but when I set the network path and user name and password, it tells me the first folder in the path there is no share??

I've never had this is issue before streaming music from my NAS to Sonos, so any suggestions would be much appreciated.


Ive just downloaded 2 DLNA Player Apps on my android device and can connect and play my music from my NAS no problem at all. So this seems to suggest that the issue is related to my Sonos system itself.

Full Factory reset of all devices???

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 5
Badge +16

Hi @dmn1981, welcome to the Sonos community. Thank you for letting us know about your concern as well as the steps that you did. Let me help you with this.

Based on the error, the Sonos app unable to connect to your music shared folder. Let me ask you a few questions for us to provide some suggestions that you can follow.

1. Any update or changes you made recently with your network?
2. Were you able to access the NAS drive from your computer? Did you get the same error message?
3. Have you tried removing and re-adding your music library?
4. To use a NAS drive with Sonos, the NAS must support the SMB(v1)/CIFS file-sharing protocol. Have you tried recreating the sharing permissions on the folder?
5. Have you configured your firewall to work with Sonos? 
6. Do you have an antivirus installed? You may need to check the firewall configuration settings to ensure that it's not blocking Sonos.

Please submit a diagnostic of your system and reply back with the confirmation number. This will allow us to see how your system is functioning, and help provide a resolution.

If you need help with any other information, please be sure to let us know. The Sonos Community is always here to help.