Cannot share USB audio files with SONOS v2 system music library

  • 20 September 2022
  • 3 replies

Cannot share USB audio files with SONOS v2 system
Router Model: TP-Link Archer C8
Hardware Version: V3
Firmware Version: 1.1.3 Build 20220510 rel.32759(5553)

The USB drive plugged into the Archer C8 shows it is active in the Archer C8 advanced USB settings.  All files are shared with no login required.

The network address is:  \\\sda1\USB_Music

Windows explorer can find the music files OK and can play them,  but the SONOS v2 system cannot access the music library.

I have worked extensively with TP-Link and SONOS customer support, but they were unable to resolve this problem.  SONOS suspects a problem with the TP-Link Archer C8's implementation of SMB1 and/or SMB2 protocols.

I have tried sharing the USB drive with and without user login and password, but neither works.

I just updated the router to the latest version firmware, but that did not resolve this problem.

Any suggestions from other users would be welcomed.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies



Which version of the Sonos software are you using? Which version of SMB is active on your router? What is a Sonos V2 system?


The fact that Windows can see things is only as good as telling us that there’s not an issue with the drive. Sonos tries to reach the data from the processes running (in linux) on their speakers, not from your computer, so the method is completely different. Which is why the SMB version is so important, as S1 Sonos software only can use SMB/NTML v1, and S2 software can use SMB V2 and V3.

Userlevel 7
Badge +22

Can you copy a couple tracks to your computer and try sharing them as a music library?

That would at least show if it was a just Sonos issue or not.