Answered

Cannot connect to Wi-Fi

  • 25 April 2022
  • 1 reply
  • 77 views

I have a Sonos Play:1, a Sonos One, and a Roam. The first two have been on my Wi-Fi for years now. The Roam is new. Because of the Roam, I switched from the S1 to the S2 app on my iPhone. When I did that, I lost my whole system. I don’t mind so much because all of my playlists are via connected services. My problem is that now I can only get the Roam to connect to my Wi-Fi. I’ve gone through the various articles and asked the Sonos bot. I’ve successfully connected them to my router via ethernet, but cannot connect them to the Wi-Fi from there.  I’ve reset both speakers to factory settings. I’ve rebooted my router (both in the order prescribed in various Sonos support articles). The Wi-Fi connection still fails. 

At one point, I got my Play:1 to connect to the Wi-Fi, but it would not appear on the system tab of the S2 software. That time, my router software showed all items connected, but the Sonos software said differently.

My latest attempts have been all after I have a successful wired ethernet connection and the failure happens when I try to connect to the temporary SONOS network for my phone and speaker to talk to each other and find the Wi-Fi together. 

Anyone have any ideas? TIA.

icon

Best answer by Ken_Griffiths 25 April 2022, 01:49

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

I would first ensure your routers Wireless credentials are stored in your Sonos App ‘Network Settings’ - The easiest way to ensure that, is to perhaps follow this Support document to switch your devices from Wired (SonosNet) to Wireless Mode:

https://support.sonos.com/s/article/3209

Once you have your Play:1 and Sonos One working well on your WiFi signal, then see if your Roam will connect to the system/App by powering it off and on again, if not, you might find it slightly easier to Factory Reset just that one speaker only and adding it back to your system via ‘Settings/System/Add Product’.