Cannot adjust volume buttons with Android phone unless I'm in Spotify or Sonos app

  • 4 November 2022
  • 42 replies
  • 2649 views

Userlevel 1
Badge +1

Hi Team!
 

I rented a Sonos Five for a few months on Grover and was very happy with it.

Now I purchased my own device and I ran into the following problem which is quite detrimental to the experience.

This applies to the Spotify Listening, which I always use via the Spotify App on my Android Phone.

 

Before, I could always control the volume from wherever I am.

Now I cannot control the volume unless I am currently in the Spotify or Sonos app.

If I change the volume when the phone is locked or I am outside the Spotify or Sonos app, it just controls the phone ringtone volume.
So every time I have to adjust the volume, i need  to unlock the phone, open one of the 2 apps, and control the volume. this does take up a lot of time because i need to adjust the volume very frequently.

 

I already adjusted the settings as shown in the following articles

 

Control Sonos volume with a mobile device’s hardware buttons

Control Sonos from the Android lock screen

 

Any clue on how to fix this?

Corry P 1 year ago

Hi all,

I was able to resolve this issue on my own Android 9 device in the following way:

Android Settings » Notifications » Sonos (tap the name Sonos, not the switch) » disable Background Services.

Hopefully, the same method will work on Android versions 10 and 11, though it will not work on 12 and will likely not work on versions later than 12, due to changes in the Android operating system. This fix comes from 

No official updates as of yet.

I hope this helps.

View original

42 replies

Userlevel 7
Badge +18

Hi @dani.w_nders 

Thanks for your post!

I believe this is by design - what if you were actually trying to adjust the volume of your phone’s ringtone? Also, given that multiple apps can read inputs from your volume buttons, how is the phone to know what is to get turned up or down? If you were to use the Sonos app to stop playback, then open the Netflix app (for example) to watch something but it was too loud, you wouldn’t want the volume buttons on your phone to control the volume of your Sonos speaker that is no longer even playing.

To make things worse, the Spotify app doesn’t even need to be on the same network as your Sonos speakers to be able to control them - the volume buttons would always control the Sonos volume if the connection were kept open and the Spotify app didn’t need to be open to utilise the volume controls on your phone.

I hope this helps.

Userlevel 1
Badge +1

Hi @Corry P 

I’m sorry, this does not answer my question :(

Especially because with my previous (rented) Sonos Five, I was able to do as described above. With the one I just purchased, this is not possible.

 

what if you were actually trying to adjust the volume of your phone’s ringtone?

This is something that I do very rarely. And if I want to, I can do that by opening the three-dot menu .

 


Changing the volume of my SONOS is something I do much more frequently: up to several times an hour, especially when I have guests or move around the room.

I used to be able to use my locked phone as a kind of  “volume remote control”, whereas now i need to each time unlock my phone, enter my unlock code, open the spotify or sonos app (or the three-dot-menu thing seen above) and control the desired volume.
I know this lasts like 10 seconds, but I’d love to be able to do it instantly. Especially when the volume is too loud for a conversation, I have to interrupt my guest and unlock my phone and do that, which can be distracting.
 

If you were to use the Sonos app to stop playback, then open the Netflix app (for example) to watch something but it was too loud, you wouldn’t want the volume buttons on your phone to control the volume of your Sonos speaker that is no longer even playing.

I agree - but the really cool thing was that the volume buttons were controlling my SONOS only while it was playing. 
And, even better: if my SONOS was playing (controlled by my phone), and I opened a youtube video on my phone, the volume buttons would control the youtube by default. When I would then close youtube and go to my homescreen, or even lock the phone, the volume buttons would go back to control my SONOS by default. It was just so smart.

 

This was just a few weeks ago - I wonder what happened here?
 

Userlevel 7
Badge +18

Hi @dani.w_nders 

I think I was just able to recreate something like your issue on my own phone, and I see what you mean. With Sonos being the only media app open, I should still be able to control volume with the phone’s buttons even when I switch back to my home screen, but I cannot. And that’s with the phone unlocked.

Do you have a notification from Sonos in your Android swipe-down menu saying “Stopping the service may interrupt playback notifications”?

Userlevel 7
Badge +18

Hi @dani.w_nders 

Please try going to Settings » App Preferences » Home Screen Volume Control and make sure it’s activated. It worked for me (though the message remains). While you’re on that settings page, please make sure Show Lock Screen Control is active, and try toggling Show Notifications off and on if nothing else works.

I hope this helps.

Userlevel 1
Badge +1

Hi @Corry P thank you so much for getting back to me and revisiting my question.

Do you have a notification from Sonos in your Android swipe-down menu saying “Stopping the service may interrupt playback notifications”?


Nope, I haven’t seen that - I checked Android App Notification settings and all SONOS notifications are enabled, but no notification of that sort.
Below you can find a screenshot of my swipe-down menu as music is playing from my sonos thru Spotify

 

 

 

Please try going to Settings » App Preferences » Home Screen Volume Control and make sure it’s activated. It worked for me (though the message remains).

 

Which message remains? The notification you talked about above? Not entirely sure what you mean here 😇 

About the settings: those settings were already active, I’m afraid. I tried toggling off and on - and I was able raise the volume from the home screen (🤩) for a fraction of a second (😔) then it switched back to ringtone volume control - so all in all it didn’t solve this.

 

While you’re on that settings page, please make sure Show Lock Screen Control is active, and try toggling Show Notifications off and on if nothing else works.

 

I did that as well but no luck here :(

Here’s a screenshot of the settings:

 


Any other hints of what could be wrong here?

Userlevel 7
Badge +18

Hi @dani.w_nders 

Yes - the message I was referring to is the same message I asked if you could see.

Thanks for the screenshots, and for trying those steps - with all of those settings active, and with the Sonos app having been opened at least once, you should be then seeing a notification control section much like the one for Spotify that you do have. Only tapping the X button on it should make it go away. Here’s what I see:

Without the Sonos notification there, you wouldn’t be able to control the volume via Sonos. As you have the Spotify app notification, however, it should be passing the button presses to Sonos, albeit via a different route. It is strange that the issue is occurring on both Sonos and Spotify - it has nothing to do with Android versions as mine is stuck solidly in the past.

One more thought is to make sure that Android isn’t closing down apps as soon as they are not on the screen, to save power. This will be individually controllable for each app in Android’s Settings » Applications. This is admittedly a long-shot.

I’ve flagged this with colleagues and an investigation will soon be underway.

Userlevel 1
Badge +1

Hi @Corry P 

Ok, now I see what you mean!
If I start playback from the SONOS app instead of from Spotify, I can also see that notification.

Still I cannot control the volume from the Home Screen.
I did get it to work from the lock screen for one instance, but only while SONOS was playing the music (not Spotify, which is where I mostly play the music from), but now it’s not working. Seems to be a hit or miss - mostly miss.

 

 

P.S. I just reinstalled both SONOS and Spotify and nothing changed.

Thank you sooo much for flagging this, I look forward to see what the investigation’s outcome will be.

I wish you a lovely weekend and speak soon.
Dani :)

Userlevel 1
Badge +1

Hi @Corry P, did anything come out of the investigation?

I made several other tests:

  • Tried with my Android Phone to connect with a Wifi-Home speaker from Bose. Also here it didn’t work, same problem as described above.
  • Tried with a friend’s iPhone and my SONOS. I launched Spotify and shared to my SONOS via WiFi. I was able to change the volume from the Homescreen and the Lockscreen. Beauty 👌

So it seems to be an Android issue? 
Whereas a few weeks it worked seamlessly?

Any idea on how to bring it back?

Userlevel 7
Badge +18

Hi @dani.w_nders 

No update as of yet - I will update this thread when we have a resolution. I have no time-scale to share, unfortunately.

Badge

@Corry P if it's any help, I've noticed this same issue since my Samsung phone updated to the latest version of Android (and I'm now also getting the service stop notification you mentioned above!).

It appears that Android now doesn't recognise the Sonos app as a media player and so the media volume buttons don't get activated on the Android home page.  If I'm playing music through Bluetooth headphones through Spotify, the volume buttons work as expected for media (taking priority over other volume settings eg notifications or ringtone, per my settings choices), and if I switched to a YouTube video, the volume buttons then control the volume of YouTube as the "active media source". But for some reason, this doesn't then work when you're playing media through Sonos.

Not being techy enough, I'm not sure if this is a setting in the background of the Sonos app, or an annoying feature of Android as technically the phone isn't locally playing media, it's just controlling the output of a stream via a WiFi device...? Either way, would be good to see what the answer is on this, and whether there is anything that the software folks can solve for us 😀

Thanks!

Userlevel 1
Badge +1

Hi there,

I updated my phone from Android 12 to Android 13 last night, and now it works perfectly just like before!

Even if I play from my Spotify App to my SONOS, I can change the Spotify Volume from the Home/Lock Screen by default (when I press volume buttons). 🤩
So it seems to be an Android issue as I expected.

 

@Rich86 have you tried it out?

Badge

@dani.w_nders thanks for the info! Unfortunately my phone is 1 version too old and won't be getting Android 13 so I'm stuck with Android 12 or a new phone (which I don't want as this is only just over 2 years old and works really well still!!). Never mind, at least I know the feature will work as and when I get a new phone this time next year!!

Userlevel 1
Badge +1

Okidoke!

I confirm that after several days this still works perfectly.

I will make sure to update this thread in case anything changes.

Userlevel 2

@dani.w_nders  I have an Android 13 Pixel 7 and am NOT able to control Sonos volume from the lock screen using the volume controls. This only works if i unlock the phone and open the Sonos app.

It used to work from the lock screen until Android 12 was upgraded to 13 about a year or so ago. 

Is my understanding correct that you are able to adjust Sonos volume with the volume controls when the phone is locked?

Thanks

Userlevel 1
Badge +1

@dani.w_nders

Is my understanding correct that you are able to adjust Sonos volume with the volume controls when the phone is locked?

That's correct! It works by default. 

Both on the home screen and also when the phone is locked, screen off. If I press the volume buttons it controls the Sonos volume. 

Both when Sonos is playing music but even if the Spotify app is playing music through the Sonos. 

I'm using android 13, Samsung s21

Sorry it's not been working for you :(

Userlevel 2

Thanks @dani.w_nders  - Interesting that this must be a Pixel specific issue then. I did read that there was some ongoing bun-fight between Sonos and Google but would have thought this would have impacted all Android implementations not just Pixel. I wonder if any other Pixel users reading this have run into this issue - especially if they have found a work-around.

I have a pixel 6a, running android 13 and am having the same issue. This function used to work fine on my pixel 2, whether I was controlling music through Sonos or Spotify.  

Userlevel 7
Badge +18

Hi all,

I was able to resolve this issue on my own Android 9 device in the following way:

Android Settings » Notifications » Sonos (tap the name Sonos, not the switch) » disable Background Services.

Hopefully, the same method will work on Android versions 10 and 11, though it will not work on 12 and will likely not work on versions later than 12, due to changes in the Android operating system. This fix comes from 

No official updates as of yet.

I hope this helps.

Userlevel 1

Pixel 5, Android 13, Sonos S2 14.20.1 build 70436090 I have both Home Screen Volume Control and Lock Screen Controls turned on, but neither of them work, as @dani.w_nders described above. Android 13 didn’t resolve the issue. I also notice that when I click the 3 dots under my volume control (which by default adjusts my notifications volume when Sonos is on, not media volume), I don’t see Sonos volume in the list, like I used to. 

Userlevel 7
Badge +16

Samsung S20 and Android 12 for me. 

Unless the Sonos S1 app is active on screen the volume buttons will not adjust Sonos.

Always used to do it on the Home Screen.

Badge

I do have the same issue with my Pixel 7 Pro.

It works great with my Xperia 5iii Android 13! Unfortunately it's broken so my concern is about Pixel 7

I have the same issue with the Pixel 6a, Android 13.

Userlevel 1

Same issue here on a pixel 7 with Android 13. And used to work fine from the lock screen when the phone was off on my Pixel. 3. I was thinking it was disabled because of the Google and Sonos patent fight. But good to hear that it's not and it may just be an app issue.

 

I just turned on "home screen volume control" per this thread but no luck.

Userlevel 1

I have the Sonos notification up and the extra one "stopping the service may interrupt playback notifications" which is super confusing and a poor UX. You can see in the screenshot that I'm trying to press the volume and it is not adjusting Sonos but instead my Android media volume.

 

 

Userlevel 1

I just submitted a diagnostic, the code is 110075206.

 

Reply