Can't play music from music library..

  • 21 September 2020
  • 6 replies

Error message:  Unable to play music title.m4a - the file //iMac/Music/Users/myname/Desktop/My iTunes Backup/iTunes/iTunes Media/Music/Artist Name/Album name/Song Title.m4a cannot be found. I can play the music on my computer, but not through Sonos. This happened after I got a new computer. The majority of my music library transferred over fine - this problem only applies to about 50 songs all in the same playlist.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Have you tried updating (reindexing) the library?

Yes. Multiple times. It does not change this. The songs appear on my sonos app on my phone, which happens after reindexing. But it won’t play this group of songs.



Userlevel 6
Badge +17

Hi @libraryknit.

Welcome to the Sonos community and thanks for reaching out to us.

I would recommend the following basic troubleshooting steps:

  1. Reboot the router by unplugging it from power and plugging it back after 10-15 seconds to refresh network connectivity and delete temporary data stored on the router.
  2. Reboot your Sonos Connect.
  3. Force close and re-open the Sonos app
  4. Test if the issue persists.

After doing the basic steps above, if the issue stops then we’re good. If not I would like to recommend the following steps.

  • Open iTunes on the computer.
  • Select Songs from the left side option on iTunes.
  • Besides the song title, there is a cloud icon. Click on the cloud icon and then click on the cloud figure icon on all songs with a cloud icon beside their corresponding title. This is to download the songs to the computer since that indicates that the songs are not on the computer but is on iTunes Cloud.
  • Once all cloud icons have been clicked and removed, Remove the music library from the Sonos app.
  • Re-add the music library from the Sonos app.
  • Test to see if everything works.

I would also like to suggest the following guides to check if these things would also help fix the issue.

  1. I had to change permissions for the folder where my music is stored.  It was set to “Custom,” and I changed it to “Read & Write.”
  2. I then went to System Preferences > Security & Privacy > Privacy.  Under “Full Disc Access,” both the Sonos program AND SonosLibraryServer must be allowed.
  3. Finally, the computer name and NetBIOS name must be exactly the same in both System Preferences > Sharing - and in System Preferences > Network > Advanced > WINS.

After that, I updated the Music Library and everything was there.

Please let me know how it goes. We are always here to help out.


Someone recently also had the case where the file they were trying to play was a video file, and not only audio, which of course the Sonos can’t interpret. 

 I have tried all the solutions above, but am still getting the same error message.

Userlevel 6
Badge +17

Hi @libraryknit.

Thanks for the update and immediate response. 

I would then highly recommend contacting our technical support team for more in-depth troubleshooting steps with a screen sharing session (with your approval) so we can take a look at what is causing the issue to have this be addressed.

Please let us know how it goes so other members of the community who may be looking for answers may find your solution and try it out. We are always here to help out.