Can't play a single episode of a podcast without adding many episodes to the queue.

  • 24 July 2021
  • 2 replies

Badge +1

Trying to play a single episode of a podcast from the Stitcher service via the app doesn’t work.  If I am in the Stitcher Podcasts section of the app and select an episode and “Play now’ i get the error message “Unable to play <podcast episode name> - access is denied.’  However, if i just select the episode itself, it will play, only it also adds every single other episode of the podcast to my queue, so if I have music or other podcasts already in the queue, they are all moved down hundreds of places.  It’s extremely annoying and the error is completely uninformative.  It is definitely not an access issue, since the same episode will play if all episodes are added to the queue.  This happens consistently with any podcast.  Very frustrating bug.


Best answer by James L. 26 July 2021, 10:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Badge +17

Hi @eprparadox,


I’ve tried to reproduce this on my own system but I don’t run into the same issue as you, in regard to the “unable to play” error. If this is consistent on your system I suggest getting in touch with our support team.

Hitting “Play Now” does indeed add all of the episodes to the queue, as well as selecting one episode to be played adds all subsequent episodes to the queue. This is due to how Stitcher has arranged the section where podcasts are shown. Without going too in depth technically, the container the episodes are listed in is the same as a standard music playlist, where each “track” is intended to be played one after the other.


The only workaround I can suggest for this is instead of hitting “Play Now” is to clear the queue, and choose “Play Next” on the episode you’re looking to listen to. This will add the single episode to the queue and you can then start playback from the Now Playing screen.

Badge +1

Thanks for this suggestion but adding a single episode to the queue results in the same error.  Whether I add it and then click next track to proceed to the episode, or if i just let the current track continue to play and let it proceed naturally to the next track, in all cases once it hits that episode i get the same ‘unable to play, access is denied’ error.  Only by adding every single episode of a podcast to the queue am I able to play an episode.


I’ll get in touch with support.  Thanks!