Can’t log in but SONOS is playing from husband’s iPhone

  • 25 March 2023
  • 6 replies

My app won’t let me log in. All greyed out saying can’t connect to system. However, speaker is playing music (but even when it’s not), my husband has access to account and SONOS speaker and app works fine for him. In other words the speaker is connected to WiFi and can play though husband’s iPhone app. I have deleted my app and tried again but app thinks I’m trying to connect a speaker to the system. How can I log into the already existing account which we’ve used since we bought out first generation speakers? How can you troubleshoot if you can’t even log in?


Best answer by controlav 26 March 2023, 14:49

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +23

You shouldn’t even need to login after a fresh app install, unless your phone can’t find any devices and it thinks you should set up a new system.

Please detail exactly what prompts you are getting after an app delete / reinstall.

Your iPhone doesn’t have a corp VPN installed does it?

I am having this exact issue - have been for months - what is the answer?

There is no ‘the answer’, it depends on the situation, and there are several circumstances that could show this behaviour. 

As suggested in the previous response, more data is needed. It could be as simple as just the system, either the speakers or the controller, needing an update, or it could be a VPN issue, or a virus protection issue, or any number of other things. 

Tell us more about your system, the community will try to help. Or, you could call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.




I checked the VPN on my phone and there isn’t one set up.


I open the app and the top three options are greyed out. There is an option to find the Sonos and when I search it cannot find it. The Sonos has been moved to the router and is plugged in and the app still cannot find it, yet my husbands app can and can operate it.


I have deleted the app and re downloaded it however I can’t get the option to sign out of the app as it is greyed out. I have done updates on both my phone and the app and still no dice


Be sure to check the “silly”, such as your phone using the Guest WiFi or the Gateway WiFi access point while SONOS and your husband are using a private access point.